ArcGIS Desktop 10 Software  development software support.

298
2
Jump to solution
03-21-2012 02:33 PM
JulieBiju
Occasional Contributor
Dears,

Please do confirm the following points.Please make me correct if i am wrong.


Developing Softwares
Microsoft Visual Studio 2010 (VB.NET) Professional,
If any other VS higer version will support ,Please let me know.

Backend
SQL 2012 or SQL 2008


Weberver configeration is
4 core (1 chip) , Windows 2008 R2 (64 bit)


I am very confused when i am looking to the resourse pages.So please tell me whether the above softwares and SQL will support or not with  ArcGIS Desktop 10 Software .

regards
Julie
0 Kudos
1 Solution

Accepted Solutions
EdgarBejarano
Occasional Contributor
Microsoft Visual Studio 2010 (VB.NET) Professional is supported for ArcGIS Desktop 10 software development (ArcObjects SDK for the MS .NET Framework).  A list of supported IDEs which consists of VS2008 and VS2010 are listed in the Developer Solutions (SDK) Requirements section:


ArcObjects SDK 10 System Requirements > Developer Solutions (SDK) Requirements
http://resources.arcgis.com/content/arcgissdks/10.0/system-requirements#DeveloperSolutions

I will let others comment on the supported RDMSs.  However, the following may be helpful:

ArcSDE 10 SQL Server Database Requirements
http://resources.arcgis.com/content/arcsde/10.0/sql-server-system-requirements

A more general link where the above link is referenced:
ArcGIS Server 10 System Requirements
http://resources.arcgis.com/content/arcgisserver/10.0/arcgis-server-system-requirements

View solution in original post

0 Kudos
2 Replies
RichardWatson
Regular Contributor III
System requirements for server:

http://resources.arcgis.com/content/arcgisserver/10.0/arcgis-server-system-requirements

System requirements for desktop:

http://resources.arcgis.com/content/arcgisdesktop/10.0/system-requirements

All the information you need is in the above links (it is not that confusing).

Yes, VS 2010 is supported.

http://resources.arcgis.com/content/arcgissdks/10.0/system-requirements

No, there is no higher version of VS which has been released by Microsoft.
0 Kudos
EdgarBejarano
Occasional Contributor
Microsoft Visual Studio 2010 (VB.NET) Professional is supported for ArcGIS Desktop 10 software development (ArcObjects SDK for the MS .NET Framework).  A list of supported IDEs which consists of VS2008 and VS2010 are listed in the Developer Solutions (SDK) Requirements section:


ArcObjects SDK 10 System Requirements > Developer Solutions (SDK) Requirements
http://resources.arcgis.com/content/arcgissdks/10.0/system-requirements#DeveloperSolutions

I will let others comment on the supported RDMSs.  However, the following may be helpful:

ArcSDE 10 SQL Server Database Requirements
http://resources.arcgis.com/content/arcsde/10.0/sql-server-system-requirements

A more general link where the above link is referenced:
ArcGIS Server 10 System Requirements
http://resources.arcgis.com/content/arcgisserver/10.0/arcgis-server-system-requirements

View solution in original post

0 Kudos