Saving a 10.8 mxd to 10.7 is resulting in an error when trying to open

618
5
Jump to solution
11-19-2021 06:37 AM
Labels (1)
Michele
New Contributor III

I work for a big agency and some of us have ArcMap 10.8 and others still have 10.7. It is not an easy and quick process to upgrade those of us on the lower version so we have to save a copy as a lower version in order for those on 10.7 to be able to open the mxd's. Today we tried to do this and when any of us try to open the 10.7 version we get the following error pop up box (I cannot save a screen shot and upload it here bc my Arc is on a separate network with no internet access):

"Opening the selected ArcMap document failed.

The page layout of the map document could not be read.

The data frames of the map document could not be read due to the following error: 0x80040111 (ClassFactory cannot supply requested class)

The last successfully loaded component was: Unknown ProgID{[010F000-B6F8...]} (not sure if this is needed in it's entirety so not including all of it. Please let me know if it's needed to troubleshoot)

The specified file does not contain a valid ArcMap document or was saved using a newer version of ArcGIS."

This is the 10.7 mxd that we saved using "save a copy" and selected the "save as type" to be "ArcMap 10.7 Document".

Does anyone have any idea why this could be happening?

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
Michele
New Contributor III

Actually we've concluded that the mxd is corrupt even though the mxd doctor says there's no corrupted files.

View solution in original post

0 Kudos
5 Replies
ABishop
Regular Contributor III

Hello Michele,

So sorry to hear you are having trouble.  I found a thread on gis stack exchange that contains a similar error.  See if any of the troubleshooting suggestions help you (see link to thread below).  If not, please let me know and I'll try to help further.

https://gis.stackexchange.com/questions/165733/opening-selected-arcmap-document-failed 

Amanda Bishop, GISP
0 Kudos
Michele
New Contributor III

Thanks for that link Amanda.  I was searching on GIS stack exchange for this issue but this thread did not come up.  It's so weird because I cannot save a copy as any 10.x except for 10.0 without getting that error when trying to open it.  However, any features we created in data view (hatched border) within the layout view are very "fuzzy"  the resolution is very poor and looks like a low res picture.  And then if you try to select something in map view (within the layout view)  all the features disappear.  Bottom line, the saving as a previous arc version should work.  

0 Kudos
ABishop
Regular Contributor III

You're welcome.  Just a thought... have you been testing all of this on one machine?  Could it be that you need to repair your desktop software?  Or maybe there is a client or patch needed?

Amanda Bishop, GISP
0 Kudos
Michele
New Contributor III

Actually we've concluded that the mxd is corrupt even though the mxd doctor says there's no corrupted files.

0 Kudos
ABishop
Regular Contributor III

Ah OK... well I am glad you figured that out!  Sometimes change the machine or software or even the project in your case can resolve the issue!

Amanda Bishop, GISP