ArcMap crash when intersecting a buffer polygon feature with a watershed polygon

192
4
Jump to solution
04-08-2020 01:32 PM
PamFroemke1
Occasional Contributor

I tried to run a python script that is intersecting a stream buffer polygon with a watershed polygon and it crashed on the same watershed ID twice. Same thing happens when doing the same thing in ArcMap using model builder. ArcMap crashes without an error. Nothing appears out of the ordinary when I look at these two polygons in a map. I've successfully done this process with other stream buffers and watersheds from the same data sets. It just doesn't like watershed #139.

Appreciate any suggestions....

Thanks,

Pam

0 Kudos
1 Solution

Accepted Solutions
KoryKramer
Community Moderator

Check and repair geometry if needed.

Check Geometry—Help | Documentation 

If you send the .dmp file from C:\Users\<user>\AppData\Local\ESRI\ErrorReports we can analyze it to see if it provides any clues.  You can either attach it or send to kkramer@esri.com.

View solution in original post

4 Replies
KoryKramer
Community Moderator

Check and repair geometry if needed.

Check Geometry—Help | Documentation 

If you send the .dmp file from C:\Users\<user>\AppData\Local\ESRI\ErrorReports we can analyze it to see if it provides any clues.  You can either attach it or send to kkramer@esri.com.

View solution in original post

PamFroemke1
Occasional Contributor

Thanks Kory - I was able to get the model to work in ArcMap and the script to work by adding a Repair Geometry process.

 

Thank you!

Pam

0 Kudos
MichaelVolz
Esteemed Contributor

Pro has an additional geometry check I believe called OGC which was able to detect errors that the ESRI geometry check was unable to find.  Just a suggestion if you have access to Pro.

PamFroemke1
Occasional Contributor

Thanks Michael - I will keep this in mind if I ever need it!

Pam

0 Kudos