Select to view content in your preferred language

Workflow manager application running slow since upgrade to 10.2.1

3630
3
03-25-2015 08:10 AM
ThomasFurcron
Occasional Contributor

We have just upgraded ArcGIS desktop from 10.1 to 10.2.1 as well as the workflow manager application.  Since the upgrade the work flow application has been running very slowly, and it appears to be related to the Job Properties tab.  When that tab is closed/not being displayed it run much faster.

Has anyone else had similar issues?

Would creating indexes on the JTX_JOBS table and other related tables help?

thanks for any help or suggestions.

Tom

0 Kudos
3 Replies
TopeBello
Occasional Contributor III

Hi Tom,

Indexing the Job_ID field would help speed things up and it is recommended, but it might only be noticeable in a database that has hundreds of thousands of jobs.

Do you have extended properties tables? Do you also have an AOI map? How long does the AOI take to load?

Thanks,

Tope

0 Kudos
ThomasFurcron
Occasional Contributor

Tope thanks for the reply.

We only have a few thousand records right now, nothing nearing the hundreds of thousands.

We do have extended properties tables, two of them and they don't take long to load, much faster then the properties tab.  We typically don't have AOI's, so I don't have a time frame for those to load.

I also went through ESRI support with the Issue, and they were able to replicate the issue, and have created a BUG incident for it.  BUG-000086618.

Unfortunately that does not really solve my issue and we are stuck trying to avoid the properties tab while working in workflow manager.

Any other suggestions or ideas would be appreciated.

Thanks

Tom

0 Kudos
TopeBello
Occasional Contributor III

Tom,

I am happy that you have this logged already with support and that they are able to reproduce it. I am sure they will be contacting you with some suggestions if the bug is still opened/active.

Thanks,

Tope

0 Kudos