Select to view content in your preferred language

Unable to set Workflow Manager Server as Server Role

1945
5
Jump to solution
10-08-2021 01:51 AM
Md_AfifAbu_Bakar
Esri Contributor

I’ve installed the ArcGIS Enterprise 10.9 and workflow manager server using two separate installation methods:

  1. Single-machine
  2. Workflow Manager Server (VM01) & ArcGIS Enterprise Base deployment (VM02)

However, on both installation, I cannot enable the workflow manager server in the portal in which it stated as “Requirements Missing” as in the attached screenshot. Portal recognize the workflow manager server license as an extension rather than as a role. In the screenshot, ArcGIS Workflow Manager Server has been authorized as server role in in ArcGIS Server Manager.

Is there any method for me to troubleshoot this?

1 Solution

Accepted Solutions
JFarmer
Esri Contributor

Hi @Md_AfifAbu_Bakar 

 

It sounds like you're just getting started with Workflow Manager Server. I'd recommend you use the standard license if you have that available as that has everything you need to get up and running. The advanced license has additional automation capabilities that you probably don't need right away.

That being said, there is a known issue with the advanced license at 10.9 where Portal does not recognize it properly. If you do not have a standard license or wish to use the advanced license, you can set the Workflow Manager server role from Portal Administrator. Change the Server Function to "WorkflowManager" and you should be good.

https://machinename.domain.com/portal/portaladmin/federation/servers/yourserver/update

Thanks,

Jonathan

View solution in original post

5 Replies
JFarmer
Esri Contributor

Hi @Md_AfifAbu_Bakar 

 

It sounds like you're just getting started with Workflow Manager Server. I'd recommend you use the standard license if you have that available as that has everything you need to get up and running. The advanced license has additional automation capabilities that you probably don't need right away.

That being said, there is a known issue with the advanced license at 10.9 where Portal does not recognize it properly. If you do not have a standard license or wish to use the advanced license, you can set the Workflow Manager server role from Portal Administrator. Change the Server Function to "WorkflowManager" and you should be good.

https://machinename.domain.com/portal/portaladmin/federation/servers/yourserver/update

Thanks,

Jonathan

Md_AfifAbu_Bakar
Esri Contributor

Thank you so much Jonathan for the solution!

0 Kudos
RaghavGupta
New Contributor III

Hi JFarmer & Md_AfifAbu_Bakar

I am also facing similar situation. for me also its showing Requirements missing. But could not figure out what to do. Can you please help me out. Please refer to below screenshot for reference.

RaghavGupta_0-1692955017918.png

 

I am not using webadaptor url. I am not sure if it i required to configure server role in Portal. Please confirm

Thanks

Raghav

0 Kudos
anbinh
by
Occasional Contributor

Hi @RaghavGupta ,

 

Have you got your problem resolved? What was your solution?

I am having a similar issue. I have licensed my user type extension at Enterprise 11.1, but also says "requirements missing".

 

Regards,

Anbin

0 Kudos
Amarz
by
Occasional Contributor II

I encountered this when I didn't have my 'ArcGIS Workflow Manager Server Standard' authorized for the server. In your Workflow Manager Server, can you confirm that this is existing under Site > Software Authorization?

0 Kudos