ExecuteGPTool step will not run successfully if auto executed during job creation

2712
1
04-10-2015 09:33 AM
deleted-user-7uOyUeQXbkI0
New Contributor III

I have an ExecuteGPTool step in my workflow that I want to run immediately after job creation.  This step is running a custom script that will use the JOB_ID to select the Job AOI and use a select by location to select a feature in another feature class that contains attributes that I want to put into my jobs extended properties table(s).  Once the properties are populated it then renames the job based upon those properties.

What I have found though is that this step will not execute properly while the same session of Workflow Manager that created the job is open. No matter what I have tried, I must close and reopen Workflow Manager before this step will work properly.  All of the below scenarios have failed:

  1. Workflow is set to auto execute upon job creation and steps auto execute during job creation.
  2. Workflow is set to auto execute upon job creation, but doesn't because the job is not assigned to the person creating the job. After the job is created, and assigning it to the user, the step still won't successfully run
  3. Workflow is NOT set to auto execute upon job creation.  After manually starting the workflow, the step still returns failure code.

In all three scenarios, if I closed and reopened WMX and then ran the step, it completed successfully.  Any idea what is going on?

Tags (2)
0 Kudos
1 Reply
NishiMishra
New Contributor III

Hello Ryan,

In this case it seems when you create a job and immediately start executing there is lock put on the JTX_Jobs table and when you try to rename the job, you cannot do it due to the lock. When you restart the application the lock is released.

I suggest you submit a Technical Support ticket for information on this and any help this may require.

Hope this helps,

Nishi

0 Kudos