Select to view content in your preferred language

WMS as Basemaps in Web AppBuilder for Developer

1855
5
10-28-2020 12:30 PM
AlexandreLavoie
New Contributor III

Hi!

I saw that WMS was not supported as basemaps in Web AppBuilder. (Basemaps gallery widget)

I can add one but it does not respond.

I'm using Portal for ArcGIS and Web App Builder for Developer.

It's possible to have WMS as Basemaps in Portal.

Do I miss somethings? or..

Am i the only one who think it would be useful to use WMS service as Basemaps in WAB?

Alex

5 Replies
AndrewSouthern
Occasional Contributor

Alexandre,

I am having the same issue.  I have a WMS service that I would like to use as a basemap within WAB.  The basemap is available in Portal but does not respond in WAB.  Doesn't make sense to me.

SushilPradhan
New Contributor II

Hi,

I am experiencing the similar issue, have you found the solution for this? I have created a web map using WMS service as a basemap, shared the webmap to Everyone and a basemap group. While configuring baemap gallery widget in Web AppBuilder, i can see the basemap but not responding. Appreciated if you can let me please?

0 Kudos
Marten
by
Occasional Contributor

it is possible to use WMS in the basemap gallery. follow these steps:

  • create a web map with the WMS that you then save and share with the world
  • create a basemap group that you share with the world
  • share the new WMS web map with this group
now when you access the Basemap icon in the viewer, you'll see it as a basemap.
 
0 Kudos
Oberbossel
New Contributor

Hi Marten,

i can create my own Basemap, but its not possible to use it in the Widget "Change Basemap" in the Web Mapping Application. My last info was, that you can't use the WMS in the Widget "Change Basemap". 

It would be fine that we can use the own WMS-Basemap in the Widget!

0 Kudos
SushilPradhan
New Contributor II

Hi,

I am experiencing the similar issue, have you found the solution for this? I have created a web map using WMS service as a basemap, shared the webmap to Everyone and a basemap group. While configuring baemap gallery widget in Web AppBuilder, i can see the basemap but not responding. Appreciated if you can let me please?

0 Kudos