Widget 2.3 does not function with Apps v1.1

1202
3
12-22-2016 02:56 AM
LouisDECOMBE
Occasional Contributor

hi, 

i've a problem with the widget edit since the new update of AGOL.

I've made a apps with Web App builder from AGOL many months ago (V1.1) that have the edit widget.

Since last update of AGOL, this edit widget does not function anymore in the wiever (but does function is the design)

i tried to save as the app without this widget and add it after, but did not work.

I think it is a pb of version of the app that does not support the new version of widget

If someone has detected this issue and have a solution, it will be great.

Thanks

louis

0 Kudos
3 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Louis,

   I would definitely agree you can not use a 2.3 version of the widget in a 1.1 version of the app. You best bet is to recreate your app in 2.3. If all you did was configure the app and widgets then the level of effort is very minimal for re-creating. If you did actual code changes the because you were using WAB dev edition then re-creating may involve more work.

0 Kudos
LouisDECOMBE
Occasional Contributor

Robert, 

Thank you for your answer. For sure, we will make a new one with AGOL 2.3.

The question is also to know if we have to make new app every time that AGOL make a updgrade...

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

No you do not. But 1.1 to 2.3 is to long to wait.

0 Kudos