Web AppBuilder Developer Edition Deployment

355
4
Jump to solution
02-11-2019 10:21 AM
NathanHeickLACSD
Occasional Contributor III

I am trying to deploy a new application to our test Windows web server, but I am having issues.  It goes into a loop and the console prints out "Waiting for API loaded." over and over.  Looking at init.js, it seems that require is undefined.  I am thinking that means that dojo is not loading properly.  Another thing is that the app goes into IE8 Enterprise Mode.  In Firefox, the last console message is "redirect from http to https" and then "undefined".  Chrome does not work either.  Is https required?  It will be setup soon, but is not right now.  When I deployed it on Amazon Cloudfront, it works fine.  Of course, I am sure that Amazon has https setup properly.

0 Kudos
1 Solution

Accepted Solutions
NathanHeickLACSD
Occasional Contributor III

Thanks Robert for all of your help.  It turns out that the issue was that the web server was set up to open in enterprise mode based on the Enterprise Mode Site List.  Once our system administrators excluded the WAB app, it worked properly.

Thanks,

Nathan

View solution in original post

0 Kudos
4 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Nathan,

   That just means that the Portal url you have in your main config.json is likely set to a https url. If you change it to http (and your org is NOT setup to force https) then you should not get the redirect issue any more.

NathanHeickLACSD
Occasional Contributor III

Thanks Robert!

The portal URL was set up using https and I believe the organization is set up to require https.  I set up the organization this past year and checked that box recognizing that was where things were going in general.  Esri has taken away the option at this time.

We were able to deploy the app on a server with https configured.  The app works properly in Chrome and Firefox, but not IE.  In IE, it switches into IE 8 enterprise mode via the X-UA-compatible meta tag.  I was able to switch it in the IE 11 developer tools to IE 11 mode and the app worked.  I am wondering if we have group policy settings for our internal servers that change the mode to IE 8 for compatibility purposes.  The Amazon hosted version of the app doesn't switch to IE 8 enterprise mode.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

IE has an intranet option that automatically switches to compatibility mode.

Go to the settings (gear icon in upper right). Click the "Compatibility View Settings" uncheck "Display intranet sites in Compatibility View" if checked.

NathanHeickLACSD
Occasional Contributor III

Thanks Robert for all of your help.  It turns out that the issue was that the web server was set up to open in enterprise mode based on the Enterprise Mode Site List.  Once our system administrators excluded the WAB app, it worked properly.

Thanks,

Nathan

0 Kudos