WAB SDK Imports of existing apps always fail

805
4
Jump to solution
10-05-2016 07:22 AM
JamesGonsoski
New Contributor III

I downloaded WAB SDK 2.1 yesterday to test capabilities. Every application I try to import from ArcGIS Online reports fails reporting that the Theme is newer. Is there any way around this? Or is the SDK only useful for new construction?

0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

James,

   The issue is that WAB dev edition (what your calling WAV SDK) is at version 2.1 and the AGOL WAB is at version 2.2 the new 2.2 WAB dev edition is scheduled to be released this week or next. Once you have WAB dev edition 2.2 then you will be able to import from WAB AGOL.

View solution in original post

4 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

James,

   The issue is that WAB dev edition (what your calling WAV SDK) is at version 2.1 and the AGOL WAB is at version 2.2 the new 2.2 WAB dev edition is scheduled to be released this week or next. Once you have WAB dev edition 2.2 then you will be able to import from WAB AGOL.

JamesGonsoski
New Contributor III

Thanks for the info. I'll keep checking for the updated release. How do you determine the current version for an application in AGOL WAB?

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

James,

  Adding the About widget is the easiest way the other is to check the apps source code in your browsers developer tools most js file will have a wab_dv=2.2 url parameter or you could look at the env.js file and see deployVersion = '2.2'; in that file.

Don't forget to mark this thread as answered by clicking on the "Correct Answer" link on the reply that answered your question.

JamesGonsoski
New Contributor III

Wow. I guess that makes some sense to hide in the 'About' widget. But I would never have figured that out without your help. Many thanks.

0 Kudos