WAB Developer version not work on http servers?

140
7
Jump to solution
3 weeks ago
Labels (1)
JasonFitzsimmons
New Contributor III

We have Server for ArcGIS 10.7.1 on our local servers, which are http only. (no Portal or Web Adapter).  In the past, we created the app and edited it through ArcGIS Online, then downloaded the code and installed that on our local servers.  We create the initial web map on ArcGIS Online with map serview we publish from mxds on the same local servers, but with an https proxy for the REST endpoint.

 

I used the developer version of WebApp Builder hosted on our local servers in the past to create web apps with custom widgets. Now I am trying, but I cannot load the editor (server.dot.nycnet:3344/webappbuilder).

 

Is this because our server is http? Or should I upgrade our WAB install? The last time I used it was fall of 2020.

0 Kudos
1 Solution

Accepted Solutions
JasonFitzsimmons
New Contributor III

Hello again, I am able to use WAB DE now, turns out it was two problems:

Esri wrote me that a bug had been identified related to my problem (BUG-000139160) which was just fixed last week.
In addition, ith the help of Esri support, I learned that I needed to change a reference in the WAB code, which was using https.

In \\webappfolder\arcgis-web-appbuilder-2.17\WebAppBuilderForArcGIS\server\signininfo.json:

"portalUrl": "https://myorg.maps.arcgis.com" changed to "http://myorg.maps.arcgis.com" 

This worked. Alternatively, I can change the reference in an already-created app:

In config.json:

"portalUrl": "https://myorg.maps.arcgis.com" changed to "http://myorg.maps.arcgis.com" 


 

View solution in original post

0 Kudos
7 Replies
BrianWilson7
Occasional Contributor

I did not know it was even possible to run without having it connected to a Portal instance or ArcGIS Online; it prompts for a Portal URL (or ArcGIS Online organization URL) on first run.

When I run it and browse to http://localhost:3344/ and it redirects me to https://localhost:3344/ after I sign in. The WABDE server creates its own self-signed certificate.

Hope this helps, Brian

When I set it up access in Portal I always put in both versions as "redirect URIs", just in case. 

http://localhost:3344/, https://localhost:3344/

BTW we're still running ArcGIS Enterprise 10.7.1 here too.

0 Kudos
JasonFitzsimmons
New Contributor III

hi, I clarified above, we do use ArcGIS Online to access WAB that is installed on our servers, where we added the code for the custom widget. So we (used to) create the app on our servers but through ArcGIs Online, using the usual WebApp Builder editor, then we download the code and host it on our local servers.

Also, the map services are hosted on our local servers as well, published from mxds and added to a web map on ArcGIS Online by using an https proxy.


0 Kudos
BrianWilson7
Occasional Contributor

It's really easy to update WABDE, so I always grab the latest one.  I think it's 2.19 right now. My impression is that it changed at some point and now both HTTP and HTTPS run on port 3344 but if I try to connect as HTTP it will switch over during the auth stage.

Once you copy the output files to your local server it does not need anything to run, just to access data. You probably figured that out already.

In production I run some things behind an nginx-based HTTPS proxy, that's always worked fine here.

0 Kudos
JasonFitzsimmons
New Contributor III

thanks..so are your servers https enabled then? THe existing applications we created months ago (before the https only restriction by AGOL)  all are working normally, I am running into this issue when trying to create a new app. 

0 Kudos
BrianWilson7
Occasional Contributor

Yes, I turned on that "use https only" option on the server years ago. It was relatively painless. For our ArcGIS server our IT guy maintains the certificates. On the reverse proxy that I run for other services like MapProxy and a photo manager I set up Let's Encrypt.

I looked to see if I could download an old copy of WABDE from Esri but could not find it. I was going to see if I could replicate your problem. It would be easier for you to download 2.19 and see if the problem goes away.

 

0 Kudos
JasonFitzsimmons
New Contributor III

Hello again, I am able to use WAB DE now, turns out it was two problems:

Esri wrote me that a bug had been identified related to my problem (BUG-000139160) which was just fixed last week.
In addition, ith the help of Esri support, I learned that I needed to change a reference in the WAB code, which was using https.

In \\webappfolder\arcgis-web-appbuilder-2.17\WebAppBuilderForArcGIS\server\signininfo.json:

"portalUrl": "https://myorg.maps.arcgis.com" changed to "http://myorg.maps.arcgis.com" 

This worked. Alternatively, I can change the reference in an already-created app:

In config.json:

"portalUrl": "https://myorg.maps.arcgis.com" changed to "http://myorg.maps.arcgis.com" 


 

View solution in original post

0 Kudos
JasonFitzsimmons
New Contributor III

Thanks for the responses.

I had also submitted a support request from Esri, and they just told me that they identified a bug on the ArcGIS side ( that was just fixed. I am now able to at least create ad edit an WAB DE based webapp.
I seem to be having some other issues, Ill post back here after I do some more testing.

 

 

0 Kudos