WAB Dev Ed - Web console error with map service layer not turning on layers

169
1
08-13-2018 03:56 PM
BrianDudek
Occasional Contributor

I am running WAB Dev. Ed locally at the moment.   I never had the issue before, but all of a sudden I am currently running into an issue with a connected map REST service.  The map service loads fine into the layerlist and sometimes I can see the attributes and sometimes I cannot, but if I check the console, I get: 

LayerListView.js?wab_dv=2.8:584 Uncaught TypeError: Cannot read property 'ctrlKey' of undefined
at Object._onRowTrClick (LayerListView.js?wab_dv=2.8:584)
at init.js:63

at this location is the code that I never altered (bold line is where error occurs):

_onRowTrClick: function(layerInfo, imageShowLegendDiv, layerTrNode, subNode, evt) {
this._changeSelectedLayerRow(layerTrNode);
var fold = this._foldSwitch(layerInfo, imageShowLegendDiv, subNode);
if(evt.ctrlKey || evt.metaKey) {
if(layerInfo.isRootLayer()) {
this.foldOrUnfoldAllRootLayers(fold);
} else {
this.foldOrUnfoldSameLevelLayers(layerInfo, fold);
}
}

If I click a layer on the application shows the loading symbol for a while and then a 500 (Internal Server Error) and a warning of a Cross-Origin Read Blocking (CORB) blocked cross-origin response.  The server is actually up and running though

Quite certain I never altered anything and it was working before sometime last week, so I am not sure if something changed automatically?

Thanks.

0 Kudos
1 Reply
RobertScheitlin__GISP
MVP Esteemed Contributor

Brain,

   You sometimes will see error like this when the map service is having issues and sluggish. My recommendation is to restart your map service or your whole ArcGIS Server and see if this resolves your issue. 

0 Kudos