WAB Attribute widget only showing 1000 records

4799
5
Jump to solution
12-16-2014 04:41 PM
AdamInglis
Occasional Contributor II

I'm finding my large record feature classes (5000+ records) are being truncated to 1000 records by the attribute widget.  The correct number of records appear when I view the layers in AGOL.  Anyone else have this issues?  I thought there might be a default option somewhere that limits the table display to 1000 records, but I haven't come across it yet.

0 Kudos
1 Solution

Accepted Solutions
AnthonyGiles
Frequent Contributor II
5 Replies
AnthonyGiles
Frequent Contributor II

Adam,

You are probably hitting the limit of features returned from your server. You can up the number in your service properties, but it is a trade of with the number of features returned and performance. From the help:

  • Maximum number of records returned by the server: Clients, such as the ArcGIS web APIs, can perform query operations to return specific information, or records, from a map service. This property specifies how many records can be returned by the server to a client for any given query operation. Specifying a large number of records to be returned by the server can slow the performance of client applications consuming your map service, such as web browsers, and your GIS server.

Regards

Anthony

AdamInglis
Occasional Contributor II

Hi Anthony,

The feature service is host by ArcGIS Online and the webmap I created in ArcGIS Online shows the correct number of records (over 1000).  The problem appears in when I view the webmap in WAB (Developer Edition).  The attribute table only shows 1000 records, is there a setting in the WAB attribute table widget I need to change?

-Adam

0 Kudos
AnthonyGiles
Frequent Contributor II

Adam,

I think hosted feature services are set to a limit of 1000 features and you do not have the control over the figure like you do with your own server. The only reference I can find to this is on this blog:

Quick Tips: Consuming Feature Services with Geoprocessing | ArcGIS Blog

Regards

Anthony

0 Kudos
AnthonyGiles
Frequent Contributor II
AdamInglis
Occasional Contributor II

Thanks Anthony, I wasn't able to edit the max records in AGOL, however, I overwrote the feature service with a new service and edited the max records before I published.  I'd forgotten where that setting was.

Cheers,

Adam

0 Kudos