WAB Attribute Table Widget Displaying Coded Domain Values Instead of Description

4709
5
Jump to solution
04-02-2015 03:54 PM
MichaelPotter1
New Contributor III

Hi there,

I am using the Web App Builder Developer Edition 1.1 and I am noticing that the Attribute Table Widget is only displaying coded domain values and not the descriptions. The codes mean nothing to my users so I need the descriptions to display.

The PopUps are displaying the domain descriptions so I am not sure what the deal is with the Attribute Table.

Is anyone else experience this or have a fix?

Regards,

Michael

0 Kudos
1 Solution

Accepted Solutions
MichaelPotter1
New Contributor III

ESRI has now documented and logged this issue as BUG-000088166. The description of this bug is:

"The coded value domain descriptions displays the coded value in the Developer Edition of Web AppBuilder's attribute table rather than the description when you have customized the list of visible fields in the Attributes widget."

Hopefully there will be a resolution in the next release.

View solution in original post

5 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Michael,

   Nope I am definitely getting coded value domain descriptions and not codes.

0 Kudos
MichaelPotter1
New Contributor III

After a bit of testing it seems as though once I edit any of the fields for a layer in the Attribute Table widget then this is when any domain fields start to show the coded values instead of descriptions for that layer. If I leave the Attribute Table widget at its default configuration then the domain descriptions show but as soon as I edit a layer then any domains in that layer will then show the domain code. It may have something to do with how the Attribute Table Widget reads these fields from the config_Attribute_Table.json file.

Anyone able to reproduce this issue or have any thoughts on a solution?

0 Kudos
MichaelPotter1
New Contributor III

ESRI has now documented and logged this issue as BUG-000088166. The description of this bug is:

"The coded value domain descriptions displays the coded value in the Developer Edition of Web AppBuilder's attribute table rather than the description when you have customized the list of visible fields in the Attributes widget."

Hopefully there will be a resolution in the next release.

JessicaThompson
New Contributor III

Do we know when the next release will be?

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Jessica,

   Early August the new 1.2 version is scheduled to be released.