Upgrading widgets to v1.2

2439
3
08-13-2015 07:59 AM
DanielStoelb
Occasional Contributor III

I am working on upgrading my pre-existing site to the new developer version 1.2 and have noticed that when I start building a new site from scratch (with some custom widgets that I downloaded from the custom widgets site) that the specific widgets do not appear in the header controller widget.  However, in taking a look at the code, they appear to be in there, but don't display.  Has anyone else encountered this issue?

0 Kudos
3 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Daniel,

  When building a new site the widgets come from the StemApp directory and the upgrade process only moves widgets from your configured apps (the Server folder) and does not copy all custom widget from the StemApp folder. Bottom line is you will have to re-add custom widgets to your new 1.2 install.

0 Kudos
DanielStoelb
Occasional Contributor III

All of the custom widgets are added in the stemapp\widgets folder.  I can see that the site has the widget added in the widgets folder and is in the config.json file for the main site, but is not displaying in the headercontroller.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Daniel,

   OK now I see that it was custom widgets that were not added to an app in my library that were not copied over. I have not seen the widget missing from header issue but if you have it in one of the on screen widgets and then change to a theme that does not have on screen widgets there is an issue.

0 Kudos