Upgrade error 1.3, some widgets are newer, import is failed

3569
10
12-15-2015 07:09 AM
LeoLadefian4
Occasional Contributor

Trying to upgrade 1.2 to 1.3 and I'm receiving this error when trying to import an app to the new version: "Some widgets are newer, import is failed"  I followed this procedure:

Upgrade apps—Web AppBuilder for ArcGIS (Developer Edition) | ArcGIS for Developers

some of my apps didn't come over using the command prompt so I used the GUI interface.

0 Kudos
10 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Leo,

This happens when you have an app that uses a custom widget that was (for example version 1.2.0.1 of the widget) and then you have another app that uses version 1.2.0.4 and you import the first app. What happens is the 1.2.0.4 version of the widget is copied to the stemapp widgets folder and then 1.2.0.1 version is now trying to be copied and thus the error. Before you try to upgrade to a new version of WAB you need to do some house keeping and make sure all your apps are using the same version of widgets. Then when you upgrade you will not have an issue.

MarkCederholm
Regular Contributor II

I'm trying to import a 1.2 project into 1.3 using the GUI, and it just sits there.  It has a custom widget, but I already copied my custom widgets into the widgets folder.  Did I do something wrong?

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Mark,

   Check the [install dir]/server/apps/logs/apbuilder.log and see what the error is.

0 Kudos
MichaelMiller2
Regular Contributor

I'm seeing this error when I attempt to import a 1.2 app:

[ERROR] app - Import is failed. Name:[IDFG Planning App],Version length does not match.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Normally you see this error when you are trying to add an app that has a custom widget with manifest.json that does not has "wabVersion": "1.3",

MichaelMiller2
Regular Contributor

Probably the local layer widget then. 

Thanks for the info Robert.

0 Kudos
MarkCederholm
Regular Contributor II

No error: the session just hangs until I kill it.  I went ahead and ran the command line upgrade instead, and it worked fine.  Bit of a head scratcher, though.

0 Kudos
LeoLadefian4
Occasional Contributor

Robert, does this mean I have to upgrade the widgets in my server/apps folder in my old version of wab?  I assume that just means copying and pasting the folder as that's what I've done in the past.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Leo,

   It seems to be an issue when you have a custom widget that is part of your app that has a manifest.json that is for a WAB version that is more than one version old. So yes I would make sure that all custom widget in your WAB 1.2 apps are using the latest 1.2 version of those widgets. Then you should not have any issue upgrading.