smart editor unable to insert feature to public editable layer

461
5
Jump to solution
11-01-2021 02:48 AM
Labels (1)
OfraAi
by
New Contributor III

ArcGIS Enterprise 10.8.1.

I have feature service with insert/update/delete permission to "everyone" - meaning all users that can access the app. The users access the app as anonymous.

With Editor widget - they can create and update features.

With Smart Editor - they can only update existing features, and not insert new ones.

Does anyone knows why it happens and what could be done to solve this?

Thanks in advance

Ofra A

 

0 Kudos
1 Solution

Accepted Solutions
AlixVezina
Esri Regular Contributor

Hi @OfraAi ,

We have fixed some sign in issues in the Smart Editor in more recent updates of ArcGIS Online. You may want to try downloading the widget files from the latest WAB developer edition and using them as a Custom widget in your Portal for see if that resolves your issue.

If it does not, I would recommend contacting Technical Support so they can help troubleshoot the issue and find another workaround.

View solution in original post

5 Replies
AlixVezina
Esri Regular Contributor

Hi @OfraAi ,

Since the application is publicly shared, are you able to provide a link so we can review the issue? Thank you!

0 Kudos
OfraAi
by
New Contributor III

Hi,

The application is not really publicly shared, since the network is closed to the internet.

The situation is that when I try to add new feature, while I'm not signed in - the sign in widow apears.

Thank you

Ofra

0 Kudos
AlixVezina
Esri Regular Contributor

Hi @OfraAi ,

We have fixed some sign in issues in the Smart Editor in more recent updates of ArcGIS Online. You may want to try downloading the widget files from the latest WAB developer edition and using them as a Custom widget in your Portal for see if that resolves your issue.

If it does not, I would recommend contacting Technical Support so they can help troubleshoot the issue and find another workaround.

OfraAinemer1
New Contributor

Hi,

You recommendation helped.

I took the SmartEditor from Web AppBuilder for developers version 2.22 and registered with the portal and now it works.

Thank you very much.

Ofra Ainemer 

OfraAi
by
New Contributor III

Hi,

You recommendation helped.

I took the SmartEditor from Web AppBuilder for developers version 2.22 and registered with the portal and now it works.

Thank you very much.

Ofra Ainemer 

0 Kudos