Smart Editor Geocoder

462
1
Jump to solution
05-02-2022 12:42 PM
ahargreaves_FW
Occasional Contributor III

Hi @AlixVezina 

I am trying to use the Geocoder option within the Smart Editor (Enterprise 10.9.1.)

I have my Enterprise Utility Services Geocoder set to ArcGIS World Geocoding Service and cna successfully search for addresses using the map search tool. Further, I can validate (as shown below). However, when a user uses the widget it prompts them for AGOL creds.

ahargreaves_FW_2-1651520458496.png

 

ahargreaves_FW_0-1651520359128.png

ahargreaves_FW_1-1651520433148.png

What am I doing wrong?

 

0 Kudos
1 Solution

Accepted Solutions
AlixVezina
Esri Regular Contributor

Hi @ahargreaves_FW ,

Geocoding addresses and storing the value into a field uses credits, which means an account needs to be tied to the ArcGIS World Geocoding Service.

In ArcGIS Portal, you can store the credentials for an ArcGIS Online account to be used for consuming credits. In your organization settings, configure the Geocode utility and provide the credentials to use. Here's some related doc: Utility services—Portal for ArcGIS | Documentation for ArcGIS Enterprise

AlixVezina_0-1651521118365.png

 

This will create a new Locator item in your Portal Content.

AlixVezina_1-1651521399472.png

Make sure to use the service URL from that item as the Geocoder URL in the Smart Editor settings.

AlixVezina_2-1651521454318.png

( from your screenshot above, insert the URL here: )

AlixVezina_3-1651522166358.png

 

Once this is set, the users should not be prompted to sign in anymore, and credits will be consumed from that ArcGIS Online account directly.

 

View solution in original post

1 Reply
AlixVezina
Esri Regular Contributor

Hi @ahargreaves_FW ,

Geocoding addresses and storing the value into a field uses credits, which means an account needs to be tied to the ArcGIS World Geocoding Service.

In ArcGIS Portal, you can store the credentials for an ArcGIS Online account to be used for consuming credits. In your organization settings, configure the Geocode utility and provide the credentials to use. Here's some related doc: Utility services—Portal for ArcGIS | Documentation for ArcGIS Enterprise

AlixVezina_0-1651521118365.png

 

This will create a new Locator item in your Portal Content.

AlixVezina_1-1651521399472.png

Make sure to use the service URL from that item as the Geocoder URL in the Smart Editor settings.

AlixVezina_2-1651521454318.png

( from your screenshot above, insert the URL here: )

AlixVezina_3-1651522166358.png

 

Once this is set, the users should not be prompted to sign in anymore, and credits will be consumed from that ArcGIS Online account directly.