Search Widget Error: The highlighting of the search result does not fit itself to the actual feature

1297
12
Jump to solution
08-21-2017 12:57 PM
BenjaminHarloe
New Contributor II

Hopefully the example below is enough to show what I'm talking about. In that picture I am searching for the feature that is marked by the pink line. The search tool finds it properly however the highlighting of the result (The bright blue line) does not fit the line like it should, but rather only fits the line approximately. Does anyone know what the cause of this could be? There aren't any other hidden layers that it could be accidentally displaying in the search result as far as I know. 

0 Kudos
12 Replies
BenjaminHarloe
New Contributor II

So this is intended functionality of the API and not some sort of bug? I'm not sure if this was clear but I just want to note that the layer itself is projected perfectly fine and is right where it needs to be, it's only the highlighting aspect of the search result that is incorrect.

0 Kudos
RobertScheitlin__GISP
MVP Emeritus

Benjamin,

  It is an intended behavior (currently) The search widget will generalize the returned geometry using maxAllowableOffset of 1 to lessen the amount of data returned from the query. You can call tech support and make an enhancement request to have this configurable in the Search dijit.

BenjaminHarloe
New Contributor II

Hi Robert, thanks for all the information it is very helpful. One last question I have that I figure is worth a shot posting here rather than a new thread, is it possible to just turn of the highlighting of the search result altogether?

0 Kudos