Run Web AppBuilder for Developers under HTTP

2510
4
Jump to solution
06-17-2016 02:13 AM
ZdeněkSoldán
Occasional Contributor

Hello,

I installed Web AppBuilder for Developers on our geoportal. When I run starup.bat Web AppBuilder always start under https even if I rewrite url adress to http it switch to https again. I have a web map where services are loaded under HTTP and when I want to add this web map to web appbuilder in developer tools I see erros with mixed content:   Mixed Content: The page was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint  This request has been blocked; the content must be served over HTTPS.

Is there any possibility how to run web AppBuilder under http? Or any other solutions to this problem?

Thanks for any help.

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Zdendek,  When you mention Geoportal do you mean you have Portal on premise? If so then Portal is only run using HTTPS and your rule that you are registering is using https so the WAB dev will always be in https. If you did not mean you have on premise Portal, then make sure you delete the signininfo.json and make sure to use an http address when specifying your portal rule and go back to the registering the app sets and make sure you do not use any https address for your re-directs.

View solution in original post

4 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Zdendek,  When you mention Geoportal do you mean you have Portal on premise? If so then Portal is only run using HTTPS and your rule that you are registering is using https so the WAB dev will always be in https. If you did not mean you have on premise Portal, then make sure you delete the signininfo.json and make sure to use an http address when specifying your portal rule and go back to the registering the app sets and make sure you do not use any https address for your re-directs.

ZdeněkSoldán
Occasional Contributor

Hello Robert,

Yes I meat Portal. So is any possibility how to use web maps with http connections in WAB registred on Portal?

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Not that I am aware of.

0 Kudos
ZdeněkSoldán
Occasional Contributor

Ok,

Thank you for your answers

0 Kudos