Remove Label layer from Layer List?

4047
7
Jump to solution
07-14-2015 06:18 AM
Lars_ElmkærChwastek
Occasional Contributor

Hi Guys,

I have a web map with a few layers, one on which I have enabled labels. I have then created an app with Web Appbuilder Developer Edition (WAB), based on this web map. My issue is then, that in the layer list in the WAB, the labels are added as an individual layer. I don't want that to be visible for the users. They have to be able to see the labels in the map itself of course, but not in the layer list.

So I found this other thread:

https://community.esri.com/thread/126201

which says that you can remove layers in the WAB from the layer list by their ID (from the web map's JSON). But the label layer is not added as a layer in the web map, and is therefore not to be found in the web map's JSON.

Has anyone come across this issue before?

P.S. The funny thing is that in the online version of the WAB, labels are not added to the layer list....!

Thanks

Lars

0 Kudos
1 Solution

Accepted Solutions
LemaoWu
Esri Contributor

Hi Lars,

This issue was just addressed in the July update of  WAB (Online version). And the fix will also be available in the Developer Edition 1.2 (August). Sorry for the inconvenience.

View solution in original post

0 Kudos
7 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Lars,

    Strange that you mention the label layer is not part of the webmap json but is listed in the LayerList widget. I have not seen that.

0 Kudos
Lars_ElmkærChwastek
Occasional Contributor

This is the difference between the WAB Dev. Edition. and the web map in ArcGIS Online: An added layer called Labels...

Labels WAB2.pngLabels WAB.png

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Lars,

   OK, so when you say that it does not appear in the WebMap json you are not really talking about the JSON of the webmap like June in the other thread told you about how to get to.

0 Kudos
Lars_ElmkærChwastek
Occasional Contributor

Robert,

Ok I can see how my last entry can be misleading, but yes I am also talking about the JSON. The images was just to support my original question. I could paste the JSON in as well, but it would take up a whole lot of space! :)

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Lars,

   OK, sorry for the misunderstanding. The WAB developer version 1.2 will be available in the first week of August (that version will be the same as the July update of AGOL) and will hopefully address the issue you are seeing.

LemaoWu
Esri Contributor

Hi Lars,

This issue was just addressed in the July update of  WAB (Online version). And the fix will also be available in the Developer Edition 1.2 (August). Sorry for the inconvenience.

0 Kudos
Lars_ElmkærChwastek
Occasional Contributor

Hi Robert and Lemao,

Thank you for your answers. I'll look forward to the 1.2 version.

/Lars

0 Kudos