Query Widget Result Item Contents

8346
33
Jump to solution
03-25-2015 10:53 AM
TonyGroeneveld
New Contributor III

For the Query widget you can define which fields, alias, special type and order of  the results.  I have had no luck making these changes work or stick.

For example if you change the alias, special type or order of the result item contents and click ok.  None of the changes are saved.

0 Kudos
1 Solution

Accepted Solutions
KevinHatch
New Contributor III

I figured out our problem.  It is probably an eye rolling rookie mistake.  One of the maps was referencing the layers on our web server and one on our app server.  The ones referencing the app server didn't have the query limit restriction, the the ones referencing the web server did.  I was referencing our web server when adding the layer URL manually.

View solution in original post

33 Replies
LeaDyrholm_Hansen
New Contributor III

I have the exact same question!

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Tony and Lea,

   I can confirm that this is a bug and you need to call esri tech support and report this so that it can be fixed. Until that time you can manually update the config_Query.json file for your app and it will work fine, it just seems like the UI is not saving the changes to the json file.

LeaDyrholm_Hansen
New Contributor III

Thanks Robert, I have reported the bug to our Support Center here in Denmark and they will pass it on to Esri.

0 Kudos
TonyGroeneveld
New Contributor III

I assume the manually update of the json file only applies if you are hosting the web application yourself.  I'm running it in AGOL.

MalcolmEchaluce
Occasional Contributor

Robert,

Which config was it that we do these edits in?  Previous versions of WAB (the Beta one) has the config in the Query widget already with some json in it.  The current one only has the following:

{

     "queries": []

}

Is this the correct config file we should be editing?

Thanks!

Malcolm

0 Kudos
NicholasBarger
Occasional Contributor III

Malcolm,

Use the WAB to initially set up the Queries that you want in your app.  Once they are initially set up the config_json file will be populated.  From there you can change the alias names, query name, specify the specialtype (link, image, none) for fields.  These are the things that don't seem to be saved in the WAB UI.  You can also change the images to something more appropriate than the limited set you have to choose from as long as you use this code.  You can also tweak the size of the image.

"resultsSymbol": {

        "angle": 0,

        "xoffset": 12,

        "yoffset": 12,

        "type": "esriPMS",

        "url": "http://someURL/someimage.png",

        "contentType": "image/png",

        "width": 18,

        "height": 18

      },

0 Kudos
MalcolmEchaluce
Occasional Contributor

I imported this app in the the Developer WAB from an AGO developed on with the queries already set up.  Should I re-setup the queries in WAB Developer version or should it have (in theory) carried over properly for it to then show up in the config.json for the Query widget?

0 Kudos
NicholasBarger
Occasional Contributor III

I try not to use AGO anymore than I have to... but yes I would try setting up the Queries in the WAB UI.  I would only set up the query as far as the statement and the selected field in the output.  I would not waste the time giving any fields an alias since they do not save.

Check out the config_Query after setting up a query and see what is in the file.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Malcolm,

  In the v1.1 of WAB the actual config files that are used are stored in the [install_Dir]\server\apps\[App Num]\configs\Query\config_Query.json