Problem with Zoomgrid Widget

160
2
Jump to solution
01-27-2019 11:58 AM
Ángel_DanielSuárez_Calero
New Contributor III

Hi friends, I have a problem with Zoomgrid Widget. I used this widget with a polilyne shapefile, this widget works correctly for a lot of polylines but some of them doesn´t work correctly. I recive the message :

"Cannot read property 'geometry' of undefined". I tried "zoom to feature" in ArcGis Pro with the same polyline and it works correctly , but this reason I think that my shapefile is correct and I don´t know why I have this problem whit the Widget.  Has anyone had this problem with Zoomgrid Widget?

Regards and Thanks! 

0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Angel,

   The ZoomGrid was just an example of how to port over a JS API sample to a widget and was never meant to be a widget that I support.

dgrid in side panel with zoom to function 

Tyler,

 

  Here is a quick port of that JS API sample to a WAB Widget that you can learn from.

You will have to debug to see why the ObjectID for those polylines are having an issue.

View solution in original post

2 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Angel,

   The ZoomGrid was just an example of how to port over a JS API sample to a widget and was never meant to be a widget that I support.

dgrid in side panel with zoom to function 

Tyler,

 

  Here is a quick port of that JS API sample to a WAB Widget that you can learn from.

You will have to debug to see why the ObjectID for those polylines are having an issue.

View solution in original post

Ángel_DanielSuárez_Calero
New Contributor III

Perfect, I thank the same, I tried using other field in the widget , and every attributes worked correctly. The problem was in the shapefile.

Thanks for everything once again Robert! 

0 Kudos