Print Query Results

3418
12
Jump to solution
05-31-2016 06:25 AM
LianaSmith
Occasional Contributor II

Is it possible to connect somehow query results and attribute table? I need to have an option to print query results or export them to CSV? I know it is possible to do it through attribute table. But query results are not selected in the attribute table

0 Kudos
1 Solution

Accepted Solutions
AdrianWelsh
MVP Notable Contributor

Hi Liana,

If you are using the Query widget in WAB, then you can make the query happen as an operational layer. From there, you should be able to open the attribute table of this operational layer (which would be your queried information) and print.

View solution in original post

12 Replies
AdrianWelsh
MVP Notable Contributor

Hi Liana,

If you are using the Query widget in WAB, then you can make the query happen as an operational layer. From there, you should be able to open the attribute table of this operational layer (which would be your queried information) and print.

LianaSmith
Occasional Contributor II

Hi Adrian,

That is what I am looking for, but for some reason I don't see queried results in the attribute table. Refresh button does not help.. I checked that i am clicking "Add result as operational layer" before querying...

0 Kudos
AdrianWelsh
MVP Notable Contributor

Liana,

When I perform a query and add the result as an operational layer, I have to look at that operational layer in my Layer List. That is where I would pull down the table for it.

...

...

...

I hope this helps.

LianaSmith
Occasional Contributor II

Got it! I was manually opening the attribute table.. THANK YOU SO MUCH!

0 Kudos
AdrianWelsh
MVP Notable Contributor

No problem! If this answered your question, please be sure to mark the response as "correct".

0 Kudos
ShitalDhakal__GISP
Occasional Contributor

Hi Adrian Welsh​, I tried the same steps but the ' Open Attribute Table' button doesn't show up in the operational layer pull down menu.

For that matter, the 'Open Attribute Table' does not appear in any of my attribute table. I have enabled 'query' capability for all my services.

0 Kudos
AdrianWelsh
MVP Notable Contributor

Shital,

Do you have the attribute table widget hidden? You  may need to make it visible by clicking the eyeball thing on the box:

0 Kudos
ShitalDhakal__GISP
Occasional Contributor

Interesting, I don't have the eyeball thing in my WAB.

But if you are suggesting the attribute table tool to be enabled, I have already done so,as shown in the pic below. 

0 Kudos
AdrianWelsh
MVP Notable Contributor

Shital,

If you go in and configure your attribute table widget, are your check boxes checked on for showing the layers?

0 Kudos