Plan Routes Widget not working in Web AppBuilder

199
3
04-21-2018 04:05 PM
DonaldShaw5
New Contributor II

I have created a simple application that allows a user to load points (stops), use the Route Planner tool to route vehicles and then print the map. I am not able to get the Route Planner tool to work, not even in edit mode.  What I am currently seeing is that the Route Planner (in edit mode) does not allow me to choose the layer that I have previously loaded in the Add Data widget. I had a version where I would add the stops, then configure the Analysis widget with the Route Planner tool, and THAT would allow me to add the layer to the Route Planner tool. But that is not feasible for what I am trying to accomplish! I need the app to allow a user to upload a .csv (or hosted feature layer), and then pass that into the Route Planner tool. When that analysis is done I need the application to show that layer and let the user run whatever analysis they want from there!

0 Kudos
3 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Donald,

   I hear ya. I have a lot of wants too. But the only way to give those wants wings, is to file an enhancement request with esri tech support or do the development yourself.

0 Kudos
DonaldShaw5
New Contributor II

Thanks for the response, Robert. I wonder if Web AppBuilder does not support some of the analysis tools in live versions. 

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Donald,

  My best advice is to make that call to tech support and outline your workflow and they can give you guidance on if there is a supported path or a workaround.

0 Kudos