Near me widget, layers no longer automatically turn on

294
2
10-05-2021 06:55 PM
Damian
by
New Contributor III

Dear AGOL community,

I have a web app that uses the Near Me widget, see link below...

https://ausbats.maps.arcgis.com/apps/webappviewer/index.html?id=fe74c742e9d04230b5552b1bce874ac7

The widget suddenly stopped working. The reason why it stopped working was due to the ArcGIS Web AppBuilder September 2021 update. Specifically...

"Near Me results now only include features for configured layers that are turned on in the map (instead of automatically turning those layers on)."

So my Near Me widget (which I've called 'Bat Finder' in my app) no longer works because all of my map layers are turned off (and no longer turned on automatically when selected). Because of the update, I have to turn all of my layers on in order for the widget to work. However, my widget uses 80 overlapping polygon layers. If I turn all of my layers on, the entire map is completely blue and users cannot see the basemap if they wish to navigate to an area of interest.

Does anyone know of a workaround so that only the basemap is visible to start with, and the polygons appear when a user clicks or enters a location?

Regards, Damian

Tags (3)
2 Replies
Damian
by
New Contributor III

An update...

I've made all of my layers 'transparent' and enabled the 'set selection color' option so that after performing a search, if a user clicks one of the layers in the resulting list , an outline of the layer appears on the map. Not ideal, but it'll do.

I have however stumbled on another issue. If I include a buffer distance in my search, when a user clicks on the map, a list of layers appears as expected. However, if a user then clicks somewhere else on the map using the same buffer, only a sub-set of layers form the first list appears. Shouldn't  all the layers within the buffer appear? Am I missing something obvious or is this a glitch?

Regards, Damian

 

0 Kudos
Damian
by
New Contributor III

Update #2

I have no idea why but I unchecked the 'only draw selected layer results' option in my Near Me widget and its fixed my selection issue with buffers that I described previously.

 

0 Kudos