Layer List Widget proxy setting for Show Item Details WAB 1.3 Dev

1768
7
Jump to solution
02-29-2016 12:24 PM
DavidColey
Frequent Contributor

Hi -

Is there now a proxy setting that needs to be incorporated in my app's config.json to allow users to see my public layer's details when selecting "show item details" from the layer list widget? It seems that v 1.3 takes me to my ArcGIS Online sign in page in order to display the details for my feature layers. Or maybe the re-direct uris need to be set to my machine that's running the node js?

Thanks-

David

Tags (1)
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

David,

   OK that makes sense. Internally you always need the useProxy to be true as the site is using NodeJS and a nonstandard port. When you deploy the app it is running on your web server using the standard port 80. You will have to enable anonymous access on your orgs account to prevent the sign in once deployed, unless you are going to setup your proxy on the deployed app.

Check out the anonymous access section in the link below.

Share items—ArcGIS Online Help | ArcGIS

View solution in original post

7 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

David,

   I have not seen this. If the layer is public then you should not be getting the identity manager login. Is there any more info you can provide or is this app public?

0 Kudos
DavidColey
Frequent Contributor

Thanks Robert, the app is public, let me restore item details visibility in the layerList config and I'll shoot you the url-

David

0 Kudos
DavidColey
Frequent Contributor

Thanks again Robert - the deployed app is located at:

ArcGIS Web Application

All layers and app is shared with Everyone.

The deployed app is registered, config has appID.

The redirect uris are pointing at my local machine.

Proxy settings are set to false as I haven't finalized my urls

    "httpProxy": {

        "useProxy": false,

        "alwaysUseProxy": false,

        "url": "",

        "rules": []

    },

Interesting behavior: Internally, when I set useProxy to true, user selects show item details and are taken to my Content page, that certainly can't happen... when I reset useProxy to false, user is taken to our sign-in page. 

Externally, with useProxy set to false user sees the item details as they normally would see any publicly shared feature service.

I'm definitely missing something either with how I've shared the layers or my proxy not being set correctly.

Thanks-

David

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

David,

   OK that makes sense. Internally you always need the useProxy to be true as the site is using NodeJS and a nonstandard port. When you deploy the app it is running on your web server using the standard port 80. You will have to enable anonymous access on your orgs account to prevent the sign in once deployed, unless you are going to setup your proxy on the deployed app.

Check out the anonymous access section in the link below.

Share items—ArcGIS Online Help | ArcGIS

DavidColey
Frequent Contributor

Thanks, I'm still a little confused.  I expect my WAB edition to use my machine name and node.js port, which it does.  But my previous deployment at 1.2 didn't require anonymous access to our org, and I wasn't using  the proxy.  "Show details" went directly to my rest page.  Looks like I'm going to have to work a little harder.  I need to get proxy set up anyway . . . I'll post back my results

David

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

David,

   By default WAB apps are set to use the internal NodeJS proxy. And when you are working in WAB (non-deployed) it is authenticated using the app id and your approval of WAB to acess your portal. Once you have your app deployed everything is different as you no longer have the internal WAB proxy and need to manually setup and configure a proxy in some situations.

DavidColey
Frequent Contributor

Thanks very much Robert, that's what I thought too.. for now anonymous access is behaving well but I'll still need to get my proxy setup with one of my named users, I think.

0 Kudos