Issues deploying in DEV

4125
6
Jump to solution
01-25-2015 06:07 PM
SamDrummond2
New Contributor III

I'm having issues deploying my custom widget into the stemapp\widgets folder.

I can work with my custom widget when I use a custom config file (http://[your host]/webapp/?config=sample-configs/config-demo.json) but when I add the same widget folder into [stemapp\widgets] and open the Web AppBuilder it does not appear in the list of widgets when I go to add it to an app? I have started and stopped the startup.bat file which is running node.js as per step 10 in Create a custom in-panel widget—Web AppBuilder for ArcGIS (Developer Edition) | ArcGIS for Developer...

This seem's to work with the demo app and my custom widget is basically no different. I've changed the widget name and a few items in the widget.js and widget.html files.

Has anyone else had these issues?

0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Sam,

  There is a known issue with the manifest that they have you use when following the instructions. The fix is simple just remove the double quotes from the 2D and 3D properties.

View solution in original post

6 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Sam,

   There could be several reasons it would not show up, can you post your manifest.json for the widget?

0 Kudos
TimWitt2
MVP Regular Contributor

Hey Sam,

in the stemapp/widget folder is a .repoignore file. Maybe that could be your issue?

Tim

0 Kudos
SamDrummond2
New Contributor III

Thanks for replying, here is the contents of the manifest.json file - I have litereally only changed the name, author and description settings from the demo widget. The widget is in a folder called AirQuality:

{

  "name": "AirQuality",

  "2D":"true",

  "3D":"false",

  "platform": "HTML",

  "version": "1.1",

  "wabVersion": "1.1",

  "author": "Sam Drummond",

  "description": "Air Quality Widget for example purposes",

  "copyright": "",

  "license": "http://www.apache.org/licenses/LICENSE-2.0",

  "properties": {

  "inPanel":true,

  "hasLocale": true,

  "hasStyle":true,

  "hasConfig":true,

  "hasUIFile":true,

  "hasSettingPage":true,

  "hasSettingUIFile":true,

  "hasSettingLocale":true,

  "hasSettingStyle":true,

  "IsController":false

  }

}

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Sam,

  There is a known issue with the manifest that they have you use when following the instructions. The fix is simple just remove the double quotes from the 2D and 3D properties.

SamDrummond2
New Contributor III

Thanks Robert, that worked a treat!!!

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Sam,

   Glad to help. Don't forget to mark this question as answered, by clicking on the "Correct Answer" button on the thread that answered your question.

0 Kudos