Issue Adding Attachment to related table

224
5
06-11-2018 10:59 AM
AndresCastillo
MVP Regular Contributor

I can't add attachments to a related table record.

I click add, browse for file, add.....but nothing gets added.

I have no issues adding the attachments in arcmap 10.4.1

The structure is as follows:

·         FC

·         related to

·         Inspection History Table

·         via Parent Global ID, Global ID Data Type/Child Guid, Guid Data Type

·         relate to

·         Attachment table

·         via Parent Global ID, Global ID Data Type/Child Guid, Guid Data Type

These are published as a feature access service using ArcGIS server 10.4.1.

The service is added to an AGOL web map.

The web map is consumed in a WAB DE 2.8 app.

0 Kudos
5 Replies
AndresCastillo
MVP Regular Contributor

Robert Scheitlin, GISP Champion

Do you have any tips?

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Andres,

   I don't have any experience trying to add an attachment to a related record. Your best bet would be to contact esri tech support.

AndresCastillo
MVP Regular Contributor

Thank you Robert.

0 Kudos
AndresCastillo
MVP Regular Contributor

I get a 504 error.

See the attached image for the capture from Fiddler:

Furthermore, the response TextView states:

[Fiddler] ReadResponse() failed: The server did not return a complete response for this request. Server returned 0 bytes.                                                                                                                                                                                                                                                                                                                                                                                                      

0 Kudos
AndresCastillo
MVP Regular Contributor

I am able to add the attachment on AGOL WAB, then open it.

Yet, when I try to open the same attachment on arcmap, it doesn't open.

0 Kudos