Is it possible to add a video to the 'Splash' widget?

3038
9
Jump to solution
03-16-2017 12:21 AM
PaulHaakma
Regular Contributor

Does anyone know if it's possible to embed a video within the 'Splash' widget in the WebApp Builder?

I tried the obvious, copying and pasting the iframe snippet from a YouTube Video into the html source of the content section when configuring the widget, but it won't accept it.

Doesn't necessarily have to be YouTube, although that is the obvious source. The intent would be to display a basic tutorial video that loads on startup.

Cheers,

-Paul

1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Paul,

   Adding the youtube video as an object works for me:

<object width="420" height="315"
data="https://www.youtube.com/embed/XGSy3_Czz8k">
</object>

View solution in original post

9 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Paul,

   Adding the youtube video as an object works for me:

<object width="420" height="315"
data="https://www.youtube.com/embed/XGSy3_Czz8k">
</object>
PaulHaakma
Regular Contributor

Thanks Robert, I'll test that.

Cheers.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Paul,

   If this worked for you, don't forget to mark this question as answered by clicking on the "Correct Answer" link on the reply that answered your question.

BrantCarman
Occasional Contributor

I tried your method, but it doesn't seem to work currently.  Can you tell me if this still works for you?  Might I be doing something wrong?

Thank you!

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Brant,

   Are you making sure you switch to "view html source" in the editor dialog before you paste the html code provided?

I just tested and it still works.

BrantCarman
Occasional Contributor

Yes, it is working for me now. 

Sorry, I was trying to implement this in the splash screen for the "Basic Viewer" configurable web app at first, rather than in Web AppBuilder.  In the configurable web app, the video displays in the splash screen text editor, but reverts to displaying the html code when you save and launch the app.  I just assumed they would function the same.  Bummer, because I prefer the look and style of the basic viewer configurable web app.

Thanks for your help!

0 Kudos
KateCarlson
Occasional Contributor

Thanks all for posting this.  I am able to add the youtube video in your example, but when I replace that link with my youtube video link, the video does not appear when launched.  Is there a setting I am missing or a size restriction?

Thanks-

Kate

0 Kudos
KateCarlson
Occasional Contributor

That was quick, I just answered my own question!  From Youtube, make sure to select 'embed', then copy and paste that link into the object tags.  

Kate

CarolAnnWilliams
New Contributor

This literally worked until yesterday and then I converted to HTTPS only and it's gone! This is essential for my application, anyone else having this problem?

0 Kudos