Invalid redirect_URI Web Application Builder Deployment from Server?

2682
19
Jump to solution
07-15-2016 02:52 PM
GeoffreyWest
Occasional Contributor III


I have configured an ArcGIS WebApplicationBuilder Map as an application in ArcGIS Online.  It is consumed by IIS6 on a Windows 2003 Server Machine.  When I hit the URL; I receive ERROR 400 Invalid URI_indirect.  My application was copied to my server from AGOL. What is the solution for this if I am not using WebAppBuilder in Development mode?  What should my URI be when I register the app in AGOL?

0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Geoffrey,

  The url you should use to register the app is the url that you use to see the app (i.e. http://gisdev01/LifeSupportApplication/​).

View solution in original post

0 Kudos
19 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Geoffrey,

  The url you should use to register the app is the url that you use to see the app (i.e. http://gisdev01/LifeSupportApplication/​).

0 Kudos
GeoffreyWest
Occasional Contributor III

Thanks Robert,

What about the URI error?

On Fri, Jul 15, 2016 at 3:50 PM, Robert Scheitlin, GISP <geonet@esri.com>

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Geoffrey,

You have me confused again. I thought we were talking about properly registering the app so that you would not get a URI error.

0 Kudos
GeoffreyWest
Occasional Contributor III

I am receiving an invalid URI error, but I have the correct correct URL configured in the app settings in AGOL.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Geoffrey,

OK for my testing purposes, let me see if I have your workflow correct.

  1. build WAB app using AGOL, configuring it as desired.
  2. download the app.
  3. extract the app to your local IIS
  4. open a browser and attempt to access the app and you receive invalid URI error

Is this correct?

0 Kudos
GeoffreyWest
Occasional Contributor III

Robert,

That is correct, I am prompted for a sign-in. When I click "Ok" the invalid redirect_uri

error appears.  What should this be set to in AGOL?  I have gisdev01:80

On Tue, Jul 19, 2016 at 8:37 AM, Robert Scheitlin, GISP <geonet@esri.com>

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Geoffrey,

So your app has secured services in it then?

0 Kudos
GeoffreyWest
Occasional Contributor III

It doesn't.  Once I click "Ok' as if I am going to sign in the error is thrown.  The only solution that I have seen for this is to remove the signon.json, but that is for the Dev Edition.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Geoffrey,

  OK so I created an WAB AGOL app that uses a web maps that is not shared publicly and downloaded it and deployed it to my local dev machine IIS and I was challenged by the identity manager and I entered my credentials and there was no issue at all the app came right up.

0 Kudos