Hyperlinks in ArcGIS Online

4342
9
Jump to solution
03-22-2017 10:48 AM
GeorgeKatsambas
Occasional Contributor III

I have a feature class with numerous polygons on an arcgis online map, which is also used in a Web Application Builder app v2.3 as a service. Each polygon has its on weblink(hyperlink) field that I used in arcgis online configure popups which allowed the user to click on the map and from the popup window click the hyperlink. Has the new March update to arcgis online changed the way hyperlinks are created. Link 1 image shows how the popup was and link 2 image is showing a new popup configuration. If I have a map service of over 200 polygons and each polygon has its own field with a hyperlink how do I add in to an online map and web application builder?

0 Kudos
1 Solution

Accepted Solutions
CarmelConnolly3
Occasional Contributor II

Hi George,

Are you URLs still formatted in the same way? I remember there being inconsistancies in ArcGIS Online in how URLs are recognised - www.google.com versus http://google.com

Carmel

View solution in original post

0 Kudos
9 Replies
HenryMoore
New Contributor II

I have a related question regarding email addresses. I have a column of email addresses that I would like to make active in the popup. Is that possible?

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Henry,

   For your question you would use:

<a href="mailto:"{emailField}"?Subject=Hello%20again" target="_blank">Send Mail</a>

HenryMoore
New Contributor II

Thanks Robert.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

George,

   The hyperlink button is in the one that looks like a chain link in the toolbar click on that and add the field name surrounded by curly backets for the url field. If you use the "view html source" it would look like this:

<a href="{SIADDRESS}" target="_blank">test1</a>

GeorgeKatsambas
Occasional Contributor III

In arcgis online I need to configure the popups on my map that my WAB Developer app is pointing to, however, services that I published before the march update to arcGIS online the popup window is respecting the hyperlink.  Services that are published now the link is added using the custom attribute display window that is under the configure pop up but if my map services have numerous URL's within 1 published Feature Class I am limited to adding them. Basically in arcGIS online under configure popup adding an URL is different?

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

George,

   Are you sure that you where choosing "Custom Attribute Display" before the March release. I seem to remember it always looking that way when choosing "Custom Attribute Display".

0 Kudos
GeorgeKatsambas
Occasional Contributor III

I am trying to get one field of URLs to be hyperlinked

0 Kudos
CarmelConnolly3
Occasional Contributor II

Hi George,

Are you URLs still formatted in the same way? I remember there being inconsistancies in ArcGIS Online in how URLs are recognised - www.google.com versus http://google.com

Carmel

0 Kudos
GeorgeKatsambas
Occasional Contributor III

Thank You, i did not even realize that the URL's were wrong.