How to select data from the table using Query Widget

3505
5
03-20-2015 12:24 PM
HiroyukiMatsuda
New Contributor

I have a question regarding Query Widget of the WebApp.

I made a web application using WebApp, and put a Query widget in it.

The Query seems like working, because if I select parcels using Query, the selected parcels appear in the right pane of the Query.

But if I open the table of the selected data, it still says that “0 selected”.

Is there any way that I can select data from the table using Query widget?

0 Kudos
5 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Hiroyuki,

   In the Query widgets UI there is a check box for "Add result as operational layer" when you do this the results of the query will be added to the Attribute table widget and you will only see the queried features in that new operational layer.

0 Kudos
HiroyukiMatsuda
New Contributor

Thank you very much for your help.

I checked the box, and it worked at the first time.

The new tab was added and contains the result of the selection, which is good.

But it does not work in the same way after the second try.

Nothing was selected.

I am not sure why.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Hiroyuki,

  Yes I see what you are saying now. This seems like bug that needs to be reported to esri.

0 Kudos
HiroyukiMatsuda
New Contributor

Oh I see.

I will report this.

Thank you for your help.

0 Kudos
HiroyukiMatsuda
New Contributor

I called ESRI Support and found out that there are some inconstancy for this Widget.

  1. For the first time query, the selected data will appear in a new table which will be at the first from the left.
  2. For the second time query, the selected data will not appear by itself. After the query, you need to open Layer List, open the pulldown menu of the _Query Result Layer, and select Open Attribute Table. The selected data will appear in a new table which will be at first from the right.
  3. For the third time and later query, the same things have to be done for the second time. But the new table is blank. You have to click the Refresh button at the top of the table, then the new selection will appear in the new table.

This is sort of confusing. :(

0 Kudos