How to hide or remove ESRI default widgets

569
4
11-26-2018 02:30 PM
TyroneLigon1
New Contributor III

Due to our intranet (and probably some network restraints) we have several ESRI default widgets that don't work properly. I'd like to remove them from the Builder widget panel's default widget tab. I have tried removing a widget from the widgets/widgets-manifest.json file (nothing happens), removing a widget from the widgets/widgets-manifest-builder.json file (causes a 404 error in the widget panel), and placing an entry in the main config.json widget pool's widget list (label, uri, and visible properties) (nothing happens). None of the widgets I want to remove has an explicit manifest.json file in its directory. "Visible" does not appear to be a widget manifest attribute.

0 Kudos
4 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Tyrone,


  Web App Builder automatically searches the widget directory and list all valid widgets unless they are inside a excluded folder like the samplewidgets folder. So you can remove widget in two ways.

1. Delete the widget’s folder for the widgets folder

2. Move the widget you don’t want to the samplewidgets folder or to a new folder and add that folder to the .repoignore file

MarkEiseman2
New Contributor II

Tyrone,

Depending on the version that you are running, it is also possible that the Theme is calling to the Widget folder directly, by passing the manifest.  I would also look in the definition of the Theme of the app.

0 Kudos
TyroneLigon1
New Contributor III

Robert, thanks for the quick response. Moving the widgets did not remove the entries in the widget panel, so I ended up with buttons with broken links. I ended up removing the widget entries in the webappbuilder/stemapp/widgets/list.json file.

Mark, your suggestion wasn't a problem in my case, but after looking at the themes-manifest-builder.json file it is a possibility.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Tyrone,

   Very strange. I just tested to make sure, by moving the AddData widget folder into the samplewidget folder and then restarting WAB and creating a new app and viola there was on widget button for the AddData widget or any broken link.