How did I end up in Africa?

4056
8
Jump to solution
01-29-2015 02:20 PM
VenusScott
Occasional Contributor III

So I configured my WebMap and the use my locally installed Web Appbuilder to configure an application. I configure the Query widget as such:

and my basemap look like this based on the Webmap which is the World Streets with a City of Phoenix focus:

When I test the query:

I end up with a basemap in Nigeria Africa !!!

Bwaaaaahahaha!  Gotta Love This Stuff! Let me guess, a projection issue? Where?

1 Solution

Accepted Solutions
VenusScott
Occasional Contributor III

As it turns out, WAB has an issue when the queried results are > 1k records! If it was resolved in the 1.x release version, they broke it again

ESRI support has determined that the "projection on the fly", when used in WAB builder, is the problem where my queried records end up in Africa. ESRI is going to provide me with a BUG number to reflect this problem.

View solution in original post

8 Replies
DanPatterson_Retired
MVP Esteemed Contributor

Longitudes should be negative in North America but I doubt that is your case since it would be really off.  What coordinate system are you using?

0 Kudos
VenusScott
Occasional Contributor III

We use NAD 83 HARN StatePlane AZ... . ESRI support confirmed that even if I changed the Layer Properties to be WGS 1984 Webmercator the problem is in the code that does the projection-on-the-fly and a record limit of 1k.

0 Kudos
BenGrod
Regular Contributor

Hi Venus, I think Dan is on to something. In my experience all of the ArcGIS Online basemap content is WGS 84 (WGS_1984_Web_Mercator_Auxiliary_Sphere). Perhaps clip out a small segment of your data, reproject to WGS 84 and test it out. BTW love your photo, I've been there before Good luck

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Venus,

   I remember this being an issue in the Beta versions but they had the re-projection issue resolved in the 1.x release version.

0 Kudos
VenusScott
Occasional Contributor III

As it turns out, WAB has an issue when the queried results are > 1k records! If it was resolved in the 1.x release version, they broke it again

ESRI support has determined that the "projection on the fly", when used in WAB builder, is the problem where my queried records end up in Africa. ESRI is going to provide me with a BUG number to reflect this problem.

StanMcShinsky
Regular Contributor

Venus Scott

I was having this same problem with the Land Use Public Notification App. Everything looked good but when I did a search by address it zoomed me to Germany. I found that I missed a step in the set up.

Troubleshoot JavaScript application - Land Use Public Notification | ArcGIS for Local Government

  • Verify the data frame is projected to Web Mercator Auxiliary Sphere (WKID 102100/3857) in each map document used to publish a service. The data may remain in the local projection.

I had the data frame in a state plane projection. Once O fixed the data frame all was well. This might help for your app.

VenusScott
Occasional Contributor III

How many records were being returned? More than the 1k?

0 Kudos
StanMcShinsky
Regular Contributor

The 1k limit should only be the number of graphics drawn on the map not the projection issue. Have you taken a sample of the same data and just paired down the number of features? Do you get the same result or did that fix it?

-Stan

0 Kudos