Host a Web AppBuilder (Dev) App on Web Server

5048
18
Jump to solution
12-11-2015 09:17 AM
DeannaBurke
New Contributor II
0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Deanna,

  No once you deploy the app it does not need a port specified.

http://gis.calhouncounty.org/WAB/V1.3/widgets/eSearch/index.html

Step 7 needs to be updated in the app deployment help doc.

Jianxia Song

View solution in original post

18 Replies
MichaelRobb
Regular Contributor II

Hi,

There is a huge amount of open ended possibles... lots of details would be needed... but a place to start would be:

The AppID is for SAML and OAuth... test without.

I wouldn't set proxy at all. 

Test in Chrome or IE 11

Id make sure IIS is running properly on your web server, test by enabling anonymous.

This is definitely an architectural issue..

Since the Web application works when developing (Web Application builder).... downloading the zip.. unzip and.. dump to wwwroot.. find the folder in IIS... 'Add Application'  ... just as a test.. should work...

then start applying sercurity and such to see where the breakdown is in your setup.

RobertScheitlin__GISP
MVP Esteemed Contributor

Deanna,

   It sounds like you used an https address when you registered your portal url. Is that correct?

0 Kudos
DeannaBurke
New Contributor II

Yes. I used both http and https.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Deanna,

  No I am not talking about the App registering you did in your orgizational account online I am talking about the first time you ran WAB it asks for your orgs portal url. You can check this by opening [install dir]\server\signininfo.json file.

0 Kudos
DeannaBurke
New Contributor II

Hi, Robert.

Oh, I'm sorry. Yes. The portalUrl is an https.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

So it sounds like your web server is not https enabled and thus you are having an issue.

You really need to go back and set your WAB to use standard http. To do this delete the signininfo.json file and restart WAB and this time use the http url for your portal address. once you have done that open the app in WAB Dev again and change something small like that apps name (you can change it back latter) and save the app. Then re-download the app from WAB and try deploying again to your web server.

RobertScheitlin__GISP
MVP Esteemed Contributor

Deanna,

   You are talking about deploying a configured app downloaded from WAB Dev to a production server right?

0 Kudos
DeannaBurke
New Contributor II

Hi, Robert. Sorry for the delay. There was a crisis needing my attention.

Yes, I want to host an application that I have already configured to a web server, since I cannot do as much customization hosting on ArcGIS Online. I believe the server is https enabled, but, I did as you suggested without results. My server does not have a 3344 port, so I designated another one that was available. That wouldn't have an effect, would it?

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Deanna,

   You do not host the Web AppBuilder on your web server you download the app from WAB on your dev machine and then extract the contents of that zip file to your web server.

Deploy app—Web AppBuilder for ArcGIS (Developer Edition) | ArcGIS for Developers