geoprocessing widget output question

3506
8
06-16-2015 06:09 PM
AmyKlug
Regular Contributor

I am confused what I am supposed to put for the output in modelbuilder before I publish. When I ran the tool I used an SDE location for the output. When I ran the tool in my app I got this error

submitted.

Executing

Failed.

where can we find more information about what is actually going on? I am not sure the output is the problem or not

my output in the widget is "GPFeatureRecordSetLayer" (I am having the user add a point then create a buffer by specifying distance)

my output in the model is a feature class saved to the SDE server

Thanks in advance!

0 Kudos
8 Replies
RickeyFight
MVP Regular Contributor

Amy,

I ran into this issue yesterday. I would suggest that you gp service is not set up correctly.

Mine was not initially and got your result. I recreated it completely and it worked.

Make sure when you try the script in arcmap that the correct buffer and .lyr symbology  are added to the map.

What I was missing was that I did not have Model Parameter checked.

my model:

AmyKlug
Regular Contributor

where are you saving buffer.shp in arcmap before publishing and sharing the model?

0 Kudos
RickeyFight
MVP Regular Contributor

Amy,

I am saving them here

%SCRATCHWORKSPACE%\buffer.shp

AmyKlug
Regular Contributor

When I use the scratch database method I get this error

"the service you are trying to publish includes data but the site has been configured such that data cannot be copied to the server"

sounds like I might have to contact admin

0 Kudos
RickeyFight
MVP Regular Contributor

Amy,

Correction I am saving it to the current workspace. How are you publishing it to the server?

This is how I publish to my server.

AmyKlug
Regular Contributor

my scratch workspace is a GDB on my C drive. I have tried making it my SDE database and I can get the service to publish to the server but when I use the GP service in the geoprocessing widget in web appbuilder it throws a message it can't access the SDE database.

I get the copy error when I try to publish using scratchGDB and in_memory.

0 Kudos
RickeyFight
MVP Regular Contributor

Amy,

Can you post a link to your service so I can try it and look at it?

0 Kudos
LynnGaines
New Contributor III

Hi.  I normally put in_memory\RESULT     You don't have to use 'RESULT', however.  You can use any descriptive word.  Here is a link to more information on its use.

python - What is the proper syntax and usage for ArcGIS "in_memory" workspace? - Geographic Informat...

Hope this helps.

0 Kudos