Failed Query from Joined View with Query Widget

2962
23
10-26-2015 09:07 AM
MarieCline_Delgado
New Contributor III

I have a view joined with a feature class (one-to-one).  I have set up a query/filter in the Web App builder from the feature class to search the joined view data but the query fails. 

What reasons could cause this query to fail?  Can I query joined data? 

Thank you!

0 Kudos
23 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Marie,

   Can you share a screenshot of what your browsers web console says the error is?

0 Kudos
MarieCline_Delgado
New Contributor III

Robert,

Here are a couple screenshots. 

I have tried searching with multiple values that are known to exist and regardless of what I search I get the message that "The value entered is not valid."  Also, I have this query set up for unique values.  I would expect the drop-down arrow to produce multiple values to choose from, but that function will not work either. 

Thank you for your help!

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Marie,

   Can you attach a screen shot of your browsers web console (not just the maps image). You can access your browsers web console by pressing F12 key while your browser has focus.

0 Kudos
MarieCline_Delgado
New Contributor III

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Marie,

   You are getting close. You are on the "Elements" tab in the chrome developer tools if you can just switch to the "Console" tab and if you can undock the developer tools into a new window (by clicking the three dot stacked on top of each other just to the right of the "x" close button) that way I can see more of the console and not the webpage itself that does not help diagnose the issue.

0 Kudos
MarieCline_Delgado
New Contributor III

I'm sorry!  I am not on point today.  How about this one...   There is a lot of info.  If you would like me to expand one of the sections, let me know.  Thanks for your continued help.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Marie,

   Can you expand all the red ones

0 Kudos
MarieCline_Delgado
New Contributor III

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Marie,

   OK, not much that can help there. Can you switch to the network tab and see if you can see the url and request parameters that is being submitted to your server that it timing out?

0 Kudos