error when I import an app in WAB developer edition.

4105
8
Jump to solution
08-10-2015 12:12 PM
DiegoLlamas
Esri Contributor

Hi,

I have an app with one of the new template for WAP and I want to modify certain characteristics of some widgets  that by default WAB do not have it. I need to modify the Widget.js for some widgets and css file for other .

So I download the code for the app in my organization

because when I tried to import my app in WAB developer from my content in my account

I got this error message "Error updating application. see the log for more details"

So I tried the second option, import from PC and when I select that option and select the zip file to import the app i got unzip app error

am i doing something wrong?

Can any one help!

Thanks,

Diego Llamas

0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Diego, you can not import a version 1.2 app into WAB Dev 1.1. You will have to wait till latter this month when 1.2 Dev is available.​

View solution in original post

8 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Diego, you can not import a version 1.2 app into WAB Dev 1.1. You will have to wait till latter this month when 1.2 Dev is available.​

DiegoLlamas
Esri Contributor

Thank you Robert for your information.

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

Version 1.2 of the Web AppBuilder developer's edition is now available for download

Web AppBuilder for ArcGIS (Developer Edition) | ArcGIS for Developers

0 Kudos
DiegoLlamas
Esri Contributor

Thank you, I downloaded it already. I have a question, Maybe you could help me with this.

I am trying to modify json files from my app. I want that every time I open my app, my layer list and my legend always appear activated. I have been checking widget.js file for those widgets but i haven been able to modify my app, by any chance, do you know what do I have to change to have this behavior?

thanks Rebecca.

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

Diego,

I noticed a help doc https://developers.arcgis.com/web-appbuilder/sample-code/open-a-widget-at-application-start.htm is currently coming up with a 404 error (I notified esri).  It may be that this is no longer applicable with 1.2, since it was last updated in May.

There is a sample for opening multiple widgets   Open multiple widgets simultaneously—Web AppBuilder for ArcGIS (Developer Edition) | ArcGIS for Deve...

And there are other discussions that may be of interest

How to programmatically open a widgetOnScreen widget

Load In-Panel Widget onStart of the application

I would maybe start with those.

DiegoLlamas
Esri Contributor

Thank you Rebecca for your help!

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Diego,

  In WAB 1.2 all you do is click the button on the widget icon as indicated in the attached image

Preview.jpg

DiegoLlamas
Esri Contributor

Hi Robert,

Thank you very much for your information. That option only allow me to open one widget at time when the app start and I need two of them, so i modify Config.json file like this for the two widgets and that worked.

Thanks