Edit Layers in Web AppBuilder

1942
12
Jump to solution
06-01-2017 06:38 AM
PhilippGlaser
New Contributor II

Dear Sir or Madam,

I need help with following issue: 

I have loaded some layers into the Web AppBuilder (Developers Edition). 

The layers are displayed correctly in the map.

If I want to edit these layers with Batch Attribute Editor or with Smart Editor, these Layers are not listed as editable Layers.

I would be very grateful if you could help me with this issue.

Thanks in advance,

Philipp

Web AppBuilder for ArcGIS

#Edit Layers

#Batch Attribute Editor

#Smart Editor

0 Kudos
1 Solution

Accepted Solutions
JakeSkinner
Esri Esteemed Contributor

I would try recreating the Web Application with Web AppBuilder to see if this resolves the issue.

View solution in original post

12 Replies
JakeSkinner
Esri Esteemed Contributor

Hi Phillip,

Is the layer editable using the 'Edit' widget?  Also, are you able to edit the layer in the web map?  Be sure you are using a Feature Service, and not a Map Service.

PhilippGlaser
New Contributor II

Hi Jake!

no, i can´t select this layer with the edit-widget. No Layer is listed in the editable-Layers-list. Geoprocessing with the layer is possible anyway. Where can i choose between Feature Service/Map Service?

Thanks,

Philipp

0 Kudos
JakeSkinner
Esri Esteemed Contributor

Hi Phillip,

Are you creating the Web AppBuilder Application from a Web Map you created in either ArcGIS Online or Portal for ArcGIS?

PhilippGlaser
New Contributor II

Hi Jake,

thanks for your fast reply. I tried it with both a new and an existing web map file (which i created in Portal for ArcGIS). Is it correct that the layer should be listed in the red circled field?

Thanks,

Philipp

0 Kudos
PhilippGlaser
New Contributor II

The layer is listed as an operational layer. I can use the edit-widget in the configuration mode. But if i want to launch the app or if i want to use smart editor or batch attribute editor, no layer is listed.

0 Kudos
PhilippGlaser
New Contributor II

Feature Creation is deactivated for all layers. Where can i activate this setting?

0 Kudos
JakeSkinner
Esri Esteemed Contributor

If this is a hosted feature service, you can go to the Item Details > Settings tab and enable it there:

If it is a ArcGIS Server service, you will need to right-click on the service in ArcMap's Catalog window > Service Properties > enable Feature Access under Capabilities.

PhilippGlaser
New Contributor II

Hi Jake, it is a hosted feature service. I enabled editing, and tried it out with all other settings (e.g. synchronizing), but the problems are still there. 

I only tried this out with a standard 2D web map. 

Could this work with the editor web map? The problem in the editor web map is, that i am not able to load the layer and the widgets into the map.  

Thanks in advance,

Philipp

0 Kudos
JakeSkinner
Esri Esteemed Contributor

After enabling editing, are you able to edit the feature service in the Web Map?

0 Kudos