Does "Hosted Layer, View" break in the WAB Edit widget?

172
1
01-15-2019 06:09 AM
Highlighted
New Contributor II

I created a WAB app with a map that includes a Hosted Layer, View.  (I did this to enable private editing of the layer and public read-access of the layer.)

The Hosted Layer, View is indeed editable in the (working) map.  But in the WAB app, I get this error:

Your account does not have permission to create or modify data. Or this web map does not contain any editable layers. 

Well, the simple fact is that neither of those cases is true.  I have permission.  And the web map does indeed contain an editable layer.  (I just edited it.)

Other related threads focus on the complicated editing permissions settings.  But that's not the problem here.

I suspect that Hosted, Views behave differently, and they they break in the WAB Edit widget.

What do you think?

1 Reply
Highlighted
Occasional Contributor II

Hi Don,

I found the following information regarding this message. 

The message ""Your account does not have permission to create or modify data. Or this web map does not contain any editable layers." only appears when feature creation on the layer is disabled, making the message inaccurate. The following defect has been logged.

BUG-000115038 : The Edit Widget's Template window in WebApp Builder shows an error when a hosted feature service in ArcGIS Online set to Update Attributes Only or Update Features,is edited, reading "Your account does not have permission to create or modify data. Or this web map does not contain any editable layers," even when correct permissions and an editable layer are present.

Does this match your scenario?

Best of luck,

Marisa