Custom Prints service in WAB app 403 error when using Reverse Proxy Server Server

212
1
08-24-2020 12:03 PM
by Anonymous User
Not applicable

Service works internally but not When published outside. I had an incident with ESRI Tech support but they bailed on me when the custom service worked internally. THey mentioned that it wasn't their problem.... I am using ArcServer 10.7.7 I don't have portal installed. Reverse Proxy server is virtual and uses Plesk with Apache & nginiz. Plesk support threw it back on ESRI. I think it is related to the print service creating a new file name for the print result. I would appreciate any suggestions!

0 Kudos
1 Reply
by Anonymous User
Not applicable

Hi Les Hampton‌,

The 403 error tells us that permission to access the service is being denied. With a reverse proxy in the mix, the denial of that request could be coming from either ArcGIS Server or nginx. Starting with ArcGIS Server - what type of authentication is the server configured to use? Do we see this behaviour attempting to access unsecured services through the reverse proxy? If we set the ArcGIS Server log settings to FINE and try to access a service externally, do the attempts to access the service show up in the logs? 

Sorry to say I'm not overly familiar with Plesk and nginx, but is there some kind of logging you can enable in nginx to see how the reverse proxy is behaving when a request comes in? Typically web servers and reverse proxies will have access logging capabilities that can be enabled to provide this type of information. 

Regards,
James

0 Kudos