Can you use the Smart Editor widget to require time AND date field be filled?

921
7
Jump to solution
07-31-2020 10:00 AM
TimFlynn
New Contributor III

Can you use the Smart Editor widget to require time AND date field be filled?  I have a web app where the Date field is Date and Time, but when set to be required it only requires the Date be filled while defaulting to 12:00AM.  Is there a way to require users to update the time field?

Thanks

1 Solution

Accepted Solutions
AlixVezina
Esri Regular Contributor

This was implemented in the September 2020 update.

View solution in original post

0 Kudos
7 Replies
AlixVezina
Esri Regular Contributor

Hi Tim Flynn‌,

Thank you for bringing this up. I think you are right and the time should also be required. This will be corrected in an upcoming update of the Smart Editor widget in ArcGIS Online.

Regards,

Alix

TimFlynn
New Contributor III

Hi Alix,

Any idea when an update is scheduled?

Thanks,

Tim

0 Kudos
AlixVezina
Esri Regular Contributor

Not yet, but I will keep you posted as soon as I know more!

0 Kudos
AlixVezina
Esri Regular Contributor

This was implemented in the September 2020 update.

0 Kudos
Gabriel_David
New Contributor

Hi Alix,
This fix doesn't appear to be available at this time. In both Smart Editor and Editor widgets, the date can be chosen but not time, and that's what I need from my time enabled web app.

Thanks,

Gabe

0 Kudos
AlixVezina
Esri Regular Contributor

Hi @Gabriel_David , first please make sure time is enabled against the field in your web map.

AlixVezina_0-1619540900144.png

If that is already the case and you still cannot see the time, please try updating the date format to a different format (dropdown shown in the screenshot above), and save web map, and refresh your app.

Finally, if you still cannot see the time, please try switching that Time checkbox on and off, click OK, and save the web map again. Then go into web appbuilder and refresh the Smart Editor configuration (open the configuration for the widget and hit save).

Please let me know if any of the workarounds resolved your issue.

 

Gabriel_David
New Contributor

Hi Alix,
Thanks so much for the quick reply! I unchecked and rechecked the time enabled box on the web layers and that seems to have fixed it. I am using the classic edit widget, not smart edit.

Thanks!