Basemap Gallery widget default

3984
9
03-23-2015 07:37 AM
GeraldStanuch
New Contributor III

After adding the basemap gallery widget, no basemap displays when the app first starts.  You have to select a basemap from the widget to first have a basemap display.  Is there a way to set one of the basemaps to be selected when the app first starts?

0 Kudos
9 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Gerald,

   If you are using Web AppBuilder 1.0 and have added some basemaps to the basemap gallery widgets list then there is a bug where the json has some blank values inserted and this has to be manually fixed.

See these threads:

https://community.esri.com/thread/118906

https://community.esri.com/thread/113893

0 Kudos
GeraldStanuch
New Contributor III

I don't think that is my issue:

BaseMapGallery.jpg

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Gerald,

   OK I see your issue now. So the maps basemap is controlled by the WebMap and not the widget initially. If you want one of those basemaps to be the initial basemap then you need to edit the webmap to use that basemap.

0 Kudos
GeraldStanuch
New Contributor III

IMAGE2011 is the basemap of the webmap.  The other 3 I added.  If I don't add the Basemap Gallery widget to the app, the IMAGE2011 basemap from the webmap does display when the app starts.  If I add the Basemap Gallery widget, no basemap displays when the app first starts, unless you then pick one from the gallery.

From help, "If the basemap used in the web map is not included during the configuration, it will be automatically added when the widget opens."

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Gerald,

   Do all the basemaps have the same Spatial Reference and Levels of Display?

0 Kudos
GeraldStanuch
New Contributor III

Yes.  They are not cached.  They all display if you click on each one in the gallery.  There is a scale range set on each one so you have to zoom in a certain amount before they will display.  But after the app starts and you zoom in the basemap still does not display until you click one in the gallery.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Gerald,

   I have never run into your scenario (using none cached service as basemap with the basemap gallery widget). I would recommend you call tech support with your use case.

0 Kudos
KieranO_Donnell2
New Contributor II

Hi Robert,
I can create a basemap using two services in the Basemap Widget in Web AppBuilder, however I can't figure out how to do this in ArcGIS online.

I could change to this basemap once the app is launched, however I wish to have it load as the default basemap.
I would need to have this set as the basemap in my Web Map in ArcGIS online.


Any ideas how to do this using two services?

Cheers

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Kieran,

   I don't think there is a way in AGOL map viewer to set two layers as a basemap. I have tried many different ways and I can not find a way.

0 Kudos