Application Migration

602
4
Jump to solution
01-09-2017 01:18 PM
deleted-user-iwYtitJHBIyn
New Contributor II

Hello GeoNet Community,

I have an application that was created using Web AppBuilder 2.2.  Can this application be used in ArcGIS Online that is running Web AppBuilder 2.0?  If so, could you please provide detailed instructions on how I may achieve this task?

Thank you in advance.

Jeff

0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Jeff,

   No, you should not and likely can not use a 2.2 app in 2.0. In each release there are changes make to some widget and some core code so they are not compatible. It would be easy enough for you to install 2.2 WAB Dev edition on the other machine though.

View solution in original post

4 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Jeff,

   Your question does not make much sense. 

Can this application be used in ArcGIS Online that is running Web AppBuilder 2.0?

AGOL will always be running the latest version of WAB (which is 2.3 not 2.0).

Do you mean WAB Dev Edition 2.0?

0 Kudos
deleted-user-iwYtitJHBIyn
New Contributor II

Apologies, Robert.  Thank you for setting me straight.  I have not been using the software long, as you can tell, and the exact vernacular sometimes escapes me.

That is correct...the application was created using WAB Dev Edition 2.2...and WAB Dev Edition 2.0  is currently being used.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Jeff,

   No, you should not and likely can not use a 2.2 app in 2.0. In each release there are changes make to some widget and some core code so they are not compatible. It would be easy enough for you to install 2.2 WAB Dev edition on the other machine though.

deleted-user-iwYtitJHBIyn
New Contributor II

Thanks, Robert.  That's all I need to know.  I will look into doing just that.

Jeff

0 Kudos