App built in Web App Builder cannot be opened without logging on

4229
4
01-27-2015 07:34 AM
MarkHoover1
New Contributor II


I put together an app the other day with the web app builder and when I send the URL to someone it requires them to log on.  The content, web map, and app are all shared publically.  Also, surprisingly if I create the app using an ESRI template instead of the web app builder I am able to successfully share that app with anyone without requiring login.  Is there a step I am missing with the Web App builder that will allow the finished app to be publically viewable.


Thanks
Mark

Tags (2)
0 Kudos
4 Replies
LonSharp
Occasional Contributor II

I had the same question the other day.    Try replacing the first part of the url to your app (which starts with your organization account) with "www.arcgis.com"

So for us, I changed:  http://lakecoca.maps.arcgis.com/   to http://www.arcgis.com/

I've run across one issue with that:  The disclaimer splash I created does not carry over.   It's visible to those logging in to the organization version, but not to the public version (which is, frankly, the exact opposite of what I need).

0 Kudos
by Anonymous User
Not applicable
NathanBruce1
New Contributor III

I think it relates to the organization security settings.  You must allow for anonymous access to your organizations website. Try this hyperlink, it may explain.....Share items—ArcGIS Online Help | ArcGIS

0 Kudos
JunshanLiu
Occasional Contributor III

Could you use the latest version to have a try?

0 Kudos