Error The requested operation is unsupported by instance db FDO error: -2147155618 - Enable Network Topology

480
12
11-25-2020 11:16 AM
New Contributor III

Hello,

 

I am trying to configure a utility Network on a Oracle 19c db. 

After I create and configure a Utility Network and go to "Enable Topology" the error "The requested operation is unsupported by instance db" occurs, with FDO error: -2147155618.

I do not receive this error on SQL Server db.

 

Can anyone help me with this?

 

UNError.png.

Reply
0 Kudos
12 Replies
Esri Contributor

@RafaelFernandes_de_Souza - What version of ArcGIS Pro and ArcGIS Enterprise are you using? I am not able to reproduce using a basic UN with Oracle 19c when using ArcGIS Pro 2.7. 

What about the Utility Network? Did you apply an asset package or configure manually? Is there data loaded into the network classes? 

New Contributor III

Hello Melissa.

I am using ArcGIS Pro 2.6.3.

The Utility Network was configured manually. I created the Utility Network on SQL Server, export the Asset Package and tried to import on Oracle Geodatabase. When it fail I created a new Utility Network with the same configuration of the one of SQL Developer and at the time of Enabling Network Topology it fails.

The problem occurs when the feature classes is with data. When I try with no data, the tool execution succed. But when I try to validade topology, another error appears. A generic error.

I have configured an Oracle 19c on Staging environmet and tried to create a geodatabase to test in an isolated environmet, but I receive an error (Error creating geodatabase admin user. [ERROR: Failed to create new Oracle user sde (-51).) when trying to create the geodatabase. The print of the error when creating the geodatabase is attached.

I discovered the link https://support.esri.com/en/technical-article/000012259 for this error, but the database is not plugable.

I don't know if the error of the "Create Enteprise Geodatabase" tool is related to the problem of the Utility Network.

The production environment was updated from Oracle 11g to 19c, therefore, we have not created a geodatabase in production, because the geodatabase already exist from previous versions of Oracle.

 

Reply
0 Kudos
Esri Contributor

I loaded an asset package (with subnetwork controllers) using Pro 2.6.3 and then enabled the topology successfully.

Reply
0 Kudos
New Contributor III

Hi Paul.

Did you did it on Oracle 19c geodatabase?

 

Reply
0 Kudos
Esri Contributor

Yes he was using Oracle 19c.

Reply
0 Kudos
New Contributor III

Melissa,

Can you please upload the asset package for me to test here?

Another problem is that I cant export or import asset package from this Oracle geodatabase. I can only import/export in SQL Server geodatabase.

 

Reply
0 Kudos
Esri Contributor

What error do you get when importing/exporting from Oracle? Is it the same configuration as you have on SQL server?

Reply
0 Kudos
New Contributor III

Paul,

Is the same configuration. I will try again and send you the results.

 

Reply
0 Kudos
New Contributor III

Paul,

I created an empty Oracle db an created a enteprise geodatabase and imported the asset package with no errors.
THe error occurs only in the geodatabase that was upgrated from Oracle 11 to 19c. Did You think that the upgrade of the database may have caused the error?

 

Reply
0 Kudos