Why is font tag in Survey123 Feature Report

213
3
08-23-2020 09:27 PM
RobCahalan1
New Contributor II

I am exporting a feature report from Survey123 and the font tag is printing in the report. This survey does use white font in the survey with a black background but I do not see the tag in the attribute table. I am pulling the photo from a related (repeat) table and I am also pulling 3 other attribute values from the main layer, Wetland_Monitoring_v101.

Is there something wrong with how I am pulling the attributes from the repeat table or is there a way to have white font in the app but not on the Survey123 website?

Screen shot of the tag in the report. The tag is only around the text being pulled from the repeat table, not the main layer.

Screen shot of the Word.doc text for the report.

Screen shots of data in Survey123. The font here is white. 

0 Kudos
3 Replies
ZhifangWang
Esri Regular Contributor

Hi Rob Cahalan‌,

Would you mind sharing a copy of the XLSForm file and the report template file to zwang at esri.com so we can try to reproduce the issue? You can just leave necessary questions in those files as long as they can be used to reproduce the issue. 

0 Kudos
RobCahalan1
New Contributor II

Thanks for reaching out. I have emailed you my form and template. One thing to note is that I created this in Connect 3.9.x and I was having an issue making the select_one choice labels have white font in the Survey123 App. My work around was to place html tags around the label on the choice tab of the XLSFrom. I believe this might be the root of the issue. The tag does not remain in an exported FGDB of the data nor do I see it in the value of the attribute table but it is expressed in in the form export and on the Survey123 website.

0 Kudos
RobCahalan1
New Contributor II

I was able to fix this problem by removing the HTML tags from the choices tab in the XLSForm and republishing using Survey123 3.10. It appears my issue with the white font in the Survey123 App is no longer an issue in 3.10 and republishing removed the tags from the feature reports.

0 Kudos