Web Form Title - HTML Formatting Broken Version 3.13.239

639
3
Jump to solution
11-02-2021 11:01 AM
Kevin_Thompson
New Contributor III

Hello ESRI,

 

I recently updated my Survey123 connect to a newer version to make use of the dynamic pulling of choice lists from services in the Web Form. I noticed that now my glorious headers formatted with HTML are now no longer working? Not sure if officially this was supported functionality, but it made my Surveys looks really nice

Code: <p style="text-align:center;"><H2>Tile Assignment Form</H2><p style="text-align:center;"</p>

Originally I had this in the Settings Sheet in form_title cell. I have played around with the new settings of generated_note_form_title, but have no had any success getting it to accept the HTML formatting.

Version 3.13.239

KevinThompson1_0-1635875858863.png

 

Older Version:

KevinThompson1_1-1635875958136.png

 

 

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
Kevin_Thompson
New Contributor III

Hey all,

So I have solved my own issue! Always good to check the documentation as it is always getting updated. I see more HTML Tags are now supported which is amazing thanks ESRI! 

The issue was being caused by the Header HTML Tag (<h2>) to set the size of the text.

<p style="text-align:center;font-size:30px;"><b>Tile Assignment Form</b></p>

Just setting the size in the style fixed it!

Style your survey:

https://doc.arcgis.com/en/survey123/browser/create-surveys/styleyourform.htm

KevinThompson1_0-1635877998323.png

 

View solution in original post

0 Kudos
3 Replies
Kevin_Thompson
New Contributor III

Hey all,

So I have solved my own issue! Always good to check the documentation as it is always getting updated. I see more HTML Tags are now supported which is amazing thanks ESRI! 

The issue was being caused by the Header HTML Tag (<h2>) to set the size of the text.

<p style="text-align:center;font-size:30px;"><b>Tile Assignment Form</b></p>

Just setting the size in the style fixed it!

Style your survey:

https://doc.arcgis.com/en/survey123/browser/create-surveys/styleyourform.htm

KevinThompson1_0-1635877998323.png

 

0 Kudos
SFM_TravisBott
Occasional Contributor II

This sure gets old. 

I don't know what other software I use that I need to hang on every word of a blog post or I come back and find my products corrupted. 

Doubly annoying - the survey preview still honors the old tags, so when you're building a new survey in the old format and testing it it looks fine....until you publish it.