View Pictures of Submitted Surveys in Inbox

1644
14
Jump to solution
01-10-2021 06:41 PM
Billy
by
Occasional Contributor

Hi,

Is it possible to view the pictures taken with submitted surveys when checking the surveys in the inbox of the mobile app?

Right now when I check a submitted survey in the inbox the image question only shows the label but not pictures.

Regards.

2 Solutions

Accepted Solutions
DeonLengton
Esri Contributor

As from:

Survey123 field app (version 3.13.229)

View and add image attachments for existing records is now supported:

DeonLengton_0-1632821067509.png

 

View solution in original post

0 Kudos
Philip-Wilson
Esri Notable Contributor

Hi @MichelleWilliamsERM,

You can view images from previously collected surveys and features without having to do anything. The field app will display the existing images if they exists for those surveys, no matter then they were collected. You may need to refresh the Inbox if you already have it downloaded on the device, to ensure you get all the Inbox records.

Regards,

Phil.

View solution in original post

0 Kudos
14 Replies
JasonJordan00
Occasional Contributor

Unfortunately you can't view attachments from the inbox (and its been a huge frustration, Esri). What I've had to do in my forms is include a link to open the feature in Explorer or Collector to view attachments.

Billy
by
Occasional Contributor

It's strange that this is not implemented. While you are in the survey taking the pics for the first time you can review the pictures taken and delete them if you need to. It's the same feature, but in the inbox, and the pictures are stored in the device, so no need to get them from the server.

Thanks.

0 Kudos
CarlosDe_Angelo
New Contributor II

Yes it is, I had the same frustrating impression when I developed my survey and it was not possible to see the pictures. Thanks for posting this issue.

0 Kudos
DeonLengton
Esri Contributor

As from:

Survey123 field app (version 3.13.229)

View and add image attachments for existing records is now supported:

DeonLengton_0-1632821067509.png

 

0 Kudos
MichelleWilliamsERM
Occasional Contributor

This is a cool feature and it brought in the photo I took after installing the newest version. Is there a way to bring in the photos from before I installed the new version?

0 Kudos
Philip-Wilson
Esri Notable Contributor

Hi @MichelleWilliamsERM,

You can view images from previously collected surveys and features without having to do anything. The field app will display the existing images if they exists for those surveys, no matter then they were collected. You may need to refresh the Inbox if you already have it downloaded on the device, to ensure you get all the Inbox records.

Regards,

Phil.

0 Kudos
erica_tefft
Occasional Contributor III

Hi Phil,

I am trying to test this now. I just republished the survey at v. 3.13.234 and my field app is also at v. 3.13.234, however I can not view images when opening a record from the Inbox. I've refreshed the Inbox and I know there is an image...however it doesn't show up. 

The image is within a repeat. Would that affect my ability to see it?

Thank you,

Erica
0 Kudos
Philip-Wilson
Esri Notable Contributor

Hi @erica_tefft,

Yes, if the image question is within a repeat, you need to ensure you have query in the bind::esri:parameters column on the begin repeat question. Also, how were the existing images collected, via the Survey123 field app or web app, or another Esri app or directly added to feature layer? You need to ensure the existing images have keywords so that they can be queried and displayed against the correct image question. See following information:

https://doc.arcgis.com/en/survey123/browser/analyze-results/knownissuesanalyzeresults.htm#anchor1

https://support.esri.com/en/technical-article/000024606

Regards,

Phil.

0 Kudos
erica_tefft
Occasional Contributor III

Hi Phil,

So, my XLS has keywords (the 'name' parameter is/has always been present since the XLS was initially published), and I am using the following query statement in the begin repeat row of the bind::esri:parameters column: query allowUpdates=true

I am not using any query statement in the Image row(s) however, and after re-reading the documentation I am unsure if maybe that is my problem. Specifically here, under Images in the second paragraph, it states that if I do not want users to be able to add new images, I should add a query statement "allowAdds=false" in the bind::esri:parameters column. 

Also, these images have mostly (probably all) been added directly from the Survey123 field app on each end user's iPad, although there could be a mix of the users taking photos with the camera and attaching photos via the "file" option.

However...I did just republish the data because I needed to make some schema changes before I could make some updates to the survey. Would this impact the ability of the photos to show in the Inbox, even if they were all originally captured via the field app? 

See here for example of XLS Form parameters - this is the main repeat:

erica_tefft_0-1635165078667.png

This is the nested repeat:

erica_tefft_1-1635165127789.png

Thank you for the help.

 

 

Erica
0 Kudos